Solved

Windows suddenly will not boot with Samsung 840 pro SSD

Hi guys, I have a problem that i cannot find the solution for.

My computer today suddenly gave me the message Reboot and select proper boot device" message. It was working fine yesterday and I have no idea why it is giving me this message.

I checked bios and it is detecting the ssd hard drive.

Anybody have a solution to this? I need to use my computer for work..


I cannot start windows.

Thanks in advance
17 answers Last reply Best Answer
More about windows suddenly boot samsung 840 pro ssd
  1. i had problems before a BIOS update with my mobo, it was randomly changing the boot devices, make sure HDD is still selected as i was getting this error at each 2-3 boots...
  2. Yes the SSD is selected as first boot device. I have no clue what is going on..
  3. can you try another HDD on your PC and/or try this SSD in a friend's pc (it'll BSOD due to driver but if windows BSOD then the SSD is ok...)
  4. None of my friends have a desktop.. all laptop. I don't know how I can put it in another PC.
  5. However, I do have another HDD and it recognizes the windows on there... However, it won't start windows. It says error and it tells me to go to startup repair. The SSD doesn't even do that. It won't recognize windows at all.
  6. Ok, then the SATA ports seems to be ok, do you used the same SATA cable when testing the other HDD ??

    Also, do you have you system OS disc (windows 7 or 8), if so you can try to repair the install, maybe some file are corrupted due to a manual shutdown, power loss, etc...
  7. no, I used a different data cable.
  8. I put in the disk, but it doesn't recognize any partitions. How do I repair with the OS disk?
  9. Suddenly, the SSD works again... and it just started windows normally.. I am at a lost for words at what just happened....
  10. if the disc don't see the partition, you'll need to format and reinstall completly windows... If the install crash, your SSD drive may be dead...

    I suggest that you contact samsung, maybe it's a well known issue and they have a new firmware that corrects that, it would also be easier to RMA it if it's still not working after that as they would be aware of the issue...

    PS: i expect that you're not driving RAID and/or encrypted partition, am i ok ?
  11. It suddenly started working. It didn't even give me a startup error or anything. Is there anything I can do to prevent this from happening again? I have no idea what happened.
  12. No, I am using AHCP. Maybe I should do a firmware update?
  13. Best answer
    Maybe the SATA and or SATA power was disconnecting themselves and while moving and touching them, Bam, work again ?!?!

    Running the latest firmware is always the best but sometimes you'll need to reformat the whole thing so unless it's a listed issue corrected in the firmware note, it can be tricky...

    PS: you could also check motherboard BIOS update as maybe the SATA controller sometimes disconnect (you still see the devices but it's not trading data with them)
  14. I will keep those in mind. Thank you very much for the fast response and help! I appreciate it. Will update if anymore problems. Thanks again!
  15. Well, thank you for selecting the best answer, i'll keep an eye on this thread to see if you still have this issue and if yes, how to resolve that !!
  16. I am having the exact same problem! And don't know how to resolve! :(
  17. new samsung firmware dx06 may be solved this issue ?
Ask a new question

Read More

Boot Computers Storage