Sign in with
Sign up | Sign in
Your question
Solved

DisplayPort only giving low resolution

Last response: in Graphics & Displays
Share
August 13, 2013 10:16:54 AM

I just connected my Dell U2410 monitor to my ATI Radeon HD 7850 video card with a DisplayPort cable for the first time. (No adapters; native DisplayPort to DisplayPort.) I got a good 1920x1200 display immediately after plugging it in, but when I launched the Catalyst Control Center (to manage displays), the resolution dropped very low and an error box popped up and said higher resolutions weren't supported due to a DisplayPort issue.

Anyone have any idea what the problem might be? Based on the checking I've done, both the card and the monitor should support this resolution via DisplayPort. I'd suspect the cable, except I was getting high resolution until I launced Catalyst (of which I'm running the current version). OS: Win7 64-bit.
a b C Monitor
August 13, 2013 10:29:24 AM

May be a ver 1.1 verse version 1.2
1.2 suports higher bandwidth (Resolution)- but not sure how CCCC identifies which is which
http://en.wikipedia.org/wiki/DisplayPort

PS Some of the cables are NOT made with quality.

Added:
I have a 7850 GPU (With CCC) and am using a mini display port -> display port for my 27" 2560 x 1440 Asus PLS display
m
0
l

Best solution

a b C Monitor
August 13, 2013 10:29:33 AM

Try reloading the most current drivers and try again. Get them here:

http://support.amd.com/us/gpudownload/windows/Pages/rad...
Share
Related resources
August 13, 2013 10:37:17 AM

reinstall ccc i had the same problem when plugging in a hdmi cable in our htpc. also a good tip is to leave the displayport cable connected when you are doing all this.
m
0
l
August 13, 2013 7:36:22 PM

Thanks much for the suggestions, guys. Reinstallation of the ATI drivers did the trick. (After I figured out which ports my other monitors should be connected to.) I'm now able to run three displays (one DisplayPort, two DVI) and am a happy camper. :D 
m
0
l
!