Solved

Asus Z87M Plus fails to boot with RAM in slots A1 or A2 [SOLVED]

Got a new Asus Z87M Plus (BIOS 0703) with 32GB of Kingston HyperX Beast (KHX24C11T3K4/32X). Whenever I plug memory into slot A1 or A2, the red memory LED comes on and the board refuses to boot. I can put any two sticks of memory into B1/B2 and boot with 16GB RAM using just about any combination of RAM-related settings in BIOS, no problem. It does prefer to auto-detect the RAM as 1333 instead of 2400, but 16GB in slots B1/B2 always works. Any RAM in A1/A2 always fails.

Read some more postings, and found several who had problems with CPU sockets, coolers and so on. My missing info was i7 4770S CPU with a Cooler Master Seidon 120M liquid cooler.

I loosened the screws on the cooler and the spacers, also the screws that hold the motherboard to the cabinet. Popped out the CPU just to have a look for damage (found none) and put it back in. Now all RAM slots work OK, my guess is that the over-tightened screws caused tension in the motherboard or RAM sockets closest to the CPU.

Hope my mistake helps others with the same symptoms!
2 answers Last reply Best Answer
More about asus z87m fails boot ram slots solved
  1. Best answer
    It might be a CPU socket bent pins issue.
    Try reseating the CPU and checking the socket for bent pins.
  2. I had same issue with same mobo but 4 dimms total of 32gb.
    Obviously all my ram were OK.
    I tired everything (changing bios setting, updating bios). But I could never get the bios working with 4 *8gb ram !!
    Well what I finally did is remove the cpu fan. Open remove the cpu. And I find a very small dust stuck in the socket. I just give a big blow in the socket. Then put back the cpu. Then close the cpu. Put the cpu fan back.
    And surprise I can now use my computer with 4*8gb ram !
Ask a new question

Read More

Kingston RAM Boot Motherboards Memory Asus