Solved

The Sims 3 problem

So I bought the Humble Origin Bundle and the only game I can't play is the Sims 3.



When I click it an error shows up "Simslauncher has stopped working. After some googling I found out many people have this problem. apperently you can get around this by directly launching the game with ts3.exe, this avoids using the launcher. But when I click it (run as administrator) I get a error: C:\windows\system32\d3dx9_31.dll contains an error (or isn't suited for windows or something like that).



I have had dll errors before and was able to fix them by reinstalling directx or by extracting the dll file from a freshly downloaded directx package and manually putting it in system32. But those things haven't worked for me this time.



Things I already have tried:

-Rebooting the computer

-Reinstalling Sims 3

-Reinstalling directx (also after downloading latest version)

-Manually restoring the dll from the latest directx package

-Updating my gpu drivers

-Reinstalling origin


I don't know what to do else :( I really don't want to reinstall windows 7.
3 answers Last reply Best Answer
More about sims problem
  1. Best answer
    http://simpedia.sims2cri.com/index.php?title=D3dx9_31.dll_eng
    http://www.modthesims.info/showthread.php?t=398252

    the newest directx doesn't have that file with it. doing a search on the internet shows you solutions.
  2. computertech82 said:
    http://simpedia.sims2cri.com/index.php?title=D3dx9_31.dll_eng
    http://www.modthesims.info/showthread.php?t=398252

    the newest directx doesn't have that file with it. doing a search on the internet shows you solutions.


    I still get the error when following the steps in the first link. And for the second link I don't have dccache. Probably because I haven't even gotten in the game.
  3. nvm it works thanks!
Ask a new question

Read More

Sims Video Games DLL