Sign in with
Sign up | Sign in
Your question
Solved

OpenCL with Sony Vegas Pro 12 and Radeon 7970?

Last response: in Graphics & Displays
Share
August 15, 2013 12:02:45 PM

Anyone render using OpenCL with Sony Vegas Pro 12 and a Radeon 7970?


Everywhere I read says OpenCL/GPU doesnt work in Sony Vegas when using a 7970. Can anyone confirm this or tell me that it in fact works? If it does work for you, what are your render times?

Basically, I am looking for the best GPU (that is compatible and actually works) to render with in Sony Vegas and I know a lot of cards are not currently compatible.
August 15, 2013 12:17:40 PM

Yup and thats what I read as well, but I have also read elsewhere that there are nothing but problems. Thus why I really hope to find a specific user who has had or currently uses the 7970 to render using vegas pro 12.
m
0
l
Related resources

Best solution

a b À AMD
a c 115 U Graphics card
August 15, 2013 12:24:05 PM

entak said:
Yup and thats what I read as well, but I have also read elsewhere that there are nothing but problems. Thus why I really hope to find a specific user who has had or currently uses the 7970 to render using vegas pro 12.


I can't test it out for you specifically, but I can tell you that OpenCL is platform neutral by design. It doesn't care what the underlying device is as long as its compatible and the appropriate software tools are installed. For AMD GPUs this is a toolset called "AMD APP" or "AMD Accelerated Parallel Processing". A while back it was a separate download, then it was included as an app which could be installed along side the driver, now I believe that it's integrated directly with the driver package itself. The majority of OpenCL failures are a result of not having the appropriate software installed rather than compatibility issues with the underlying hardware.
Share
October 4, 2013 1:59:15 PM

I have a 7970. GPU acceleration doesn't work at all. It has tons of problems with freezing while rendering and using my i7 CPU renders faster. I've tried everything to make it work and searched a lot of forums.
m
0
l
April 8, 2014 8:21:03 PM

This may be an old thread but I'm telling you, MainConcept AVC on Sony Vegas Pro 12 doesn't work on R9 series.

I was using HD 6950 before I upgraded to R9 280X.

My render times with 6950 is only 10-20mins
While on R9 280X, it's 30-40mins.

The gpu is on idle too.
m
0
l
April 28, 2014 5:12:48 PM

karlsanada13 said:
This may be an old thread but I'm telling you, MainConcept AVC on Sony Vegas Pro 12 doesn't work on R9 series.

I was using HD 6950 before I upgraded to R9 280X.

My render times with 6950 is only 10-20mins
While on R9 280X, it's 30-40mins.

The gpu is on idle too.


Similar issue with a 7970Ghz Edition, used to get much better encoding speeds with my old GTX560, did you have any luck with this?
m
0
l
April 28, 2014 5:53:20 PM

Well, I am using the Sony AVC now. It kinda works, as it lessens the load on cpu from 100% to 70%-80%. But the gpu's usage is at 10%-15%
m
0
l
!