Sign in with
Sign up | Sign in
Your question
Solved

Why can't I boot off a single disk on my Dell XPS M1730 (it works only with two disks!)

Last response: in Laptop Tech Support
Share
August 16, 2013 1:01:02 AM

I need advice because I just don't understand why I can't get a single
300GB hard disk to work in my bunkbed bay Dell XPS M1730 laptop.


Two hard disks work just fine; but not ONE hard disk.
Yet, one of the hard disks is wholly unformatted!
What am I doing wrong?

Here is what the Windows 7 "Computer Management" says:


What I *want* is simply to have a single 300GB hard disk.


Yet, Windows insists on *both* disks being in the dual-slot
carrier, before it will boot.

This dual-disk combination boots to Windows 7 just fine:
Slot 0 = Win7 300GB HDD (green circuit board)
Slot 1 = unformatted 500GB HDD (blue circuit board)


But neither of these single-disk combinations will boot:
Slot 0 = empty
Slot 1 = Win7 300GB HDD (green circuit board)


Just in case I mistook the hard disk drives, I also tried:
Slot 0 = unformatted 500GB HDD (blue circuit board)
Slot 1 = empty


Slot 0 = empty
Slot 1 = unformatted 500GB HDD (blue circuit board)


The errors I get are:
No bootable devices--strike F1 to retry boot, F2 for setup utility
Press F5 to run onboard diagnostics


Or: Windows Boot Manager:
"Windows failed to start. A recent hardware or software change might be
the cause. To fix the problem:
1. Insert your windows installation disc and restart your computer
2. Choose your language settings, and then click "Next."
3. Click "Restart the computer."
If you do not have this disc, contact your system administrator or
computer manufacturer for assistance.
Status: 0xc000000e
Info: the boot selection failed because a required device is inaccessible.


Q: What's the trick to get this laptop to boot from a single disk?

Best solution

a b D Laptop
August 16, 2013 1:56:41 AM

It looks like somehow the boot manager (System Reserved) got onto disk 1, while your actual OS is on Disk 0. The boot manager gets started first, then loads the OS. Usually they're on the same drive, but something's gotten screwed up on yours.

Easiest way is to reinstall the OS with only one drive in the system, though removing the drive with the boot manager and running Startup Repair from the installation DVD might work.
Share
Related resources
a b D Laptop
August 16, 2013 3:03:32 AM

HDD's haven't been setup in raid ?
m
0
l
August 16, 2013 9:58:01 AM

Someone Somewhere said:
It looks like somehow the boot manager (System Reserved) got onto disk 1, while your actual OS is on Disk 0.


Hmmm.... Googling ... I had never installed Windows 7 before, so I was unaware of the mandatory Microsoft System Record, which you are alerting me to. I am the one who installed the operating system, and it had asked me a few questions, which I didn't understand at the time of the installation, so I had taken the default. I think that's where I had gone wrong.

Someone Somewhere said:
removing the drive with the boot manager and running Startup Repair from the installation DVD might work.


I tried Startup Repair, and it failed - although it might be because I wasn't sure WHAT hdd drivers it wanted me to point it to. Here's what I just tried:

1. I removed the 500GB hard disk drive 1 with the reserved partition. and then booted off the Windows 7 Ultimate disk with only the 300 GB HDD 0 in the dual-tier bay:


2. This popped up a language selection screen:


3. Then I hit "repair your computer" at the next screen:


4. The default was to restore your computer from an image:


5. I didn't hit that; I changed it to use recovery tools:


6. I chose the "Startup Repair" recovery tool:


7. This found, and said it repaired, a bad system partition:


8. Then it told me to restart the system, which I did (but I didn't know if that meant to restart with or without booting back to the Windows 7 Ultimate installation disk:


9. So I booted to Windows (without the ultimate disk) and it gave the error that no bootable devices were found:


10. I ran the entire sequence over again with the same results:


11. No bootable devices were found:


12. I ran this three times, all with the exact same results, but, maybe I should have found the hard disk drivers (but they're standard SATA disks - why wouldn't Windows be able to find them on its own)?



m
0
l
August 16, 2013 10:12:41 AM

das_stig said:
HDD's haven't been setup in raid ?


Funny you should mention RAID, as that's what started this whole thing!

0. Originally - there were two 300GB disks in a RAID setup on Windows XP Professional (this was set up and used by a relative, who gave me the laptop recently).

1. One of those two 300GB disks went bad (which was why I was given the laptop gratis), so, I removed the bad 300GB HDD and replaced it with the 500GB disk - but - I was totally unfamiliar with RAID, so, it didn't "just work" like I had expected it to.

2. Getting frustrated, I decided to format the 300GB disk (since none of the data was mine anyway), and I therefore made the temporal mistake of not bothering to remove the spare 500GB disk (thinking I'd remove it later).

3. Then, I installed Windows 7 Ultimate 32 bit (as I wasn't sure what the algorithm is for deciding whether to put 64 or 32 bit on a Dell XPS M1730 laptop with only 4GB of memory).

4. When I finally removed that 500GB second (I thought unused) HDD, I found, wholly to my surprise, that the machine wouldn't boot without it.

I have never worked with RAID before. What made you ask? Is RAID getting in the way, somehow, without me knowing about it?
m
0
l
August 16, 2013 10:25:14 AM



I guess you're suggesting, that I boot off the Windows 7 Ultimate disk with just the one 300GB disk in the dual-tray, and then I run that "bootrec /fixboot" procedure.

I'm not sure it will work, because it says it will write to the "current system partition", which, in my case, won't exist (since the 100MB Microsoft System Reserved partition will be on the removed disk).

Plus, I'm still going to have the problem that it will ask for HDD drivers and I won't know what it's actually looking for (the HDD drivers just installed themselves, somewhere, I don't know where, when I installed Windows 7 in the first place).

But it's worth a try. I'm going to back up the data first.

Luckily, when I put the 500GB hard disk drive back into slot 1, and booted to Windows 7, after a loooong time, Windows 7 came up, seemingly as good as it was before. Here's the manage (which isn't any different than it was before, so, that entire System Repair operation earlier today was a dismal failure).


m
0
l
August 17, 2013 6:36:35 AM

I'm thinking less and less that RAID has anything to do with my issues as it seems to be turned off by default, in the BIOS:

POST->F2->BIOS: Scrolling to Onboard Devices->SATA Operation:
RAID Autodetect/ATA = on (RAID On = off) (RAID Autodetect/AHCI = off)
RAID Autodetect / ATA = RAID if signed drives, otherwise ATA
RAID On = SATA is configured for RAQID on every boot
RAID AUTODETECT / AHCI = RAID if signed drives, otherwise ACCI
The factory default setting is RAID Autodetect / AHCI

Here's a screenshot of the current RAID settings in the BIOS:


I tried one more time to "Repair" the 32-bit operating system.

To do so, I removed the second (500GB) HDD, and started the repair process for the last time on the original HDD (320GB).


Interestingly, when I rebooted with the Windows installation CD, it has *no problem* seeing the entire HDD so, at that point, I started to doubt that SATA drivers were my problem - and began to seriously doubt the Windows Repair process.


Nonetheless, moving forward, tried to get the operating system to show up in the Repair selection box, to no avail.


One complication was that, given the single SATA driver download from Dell, there were still two different "Setup Information" files to choose from:


And, each of those collections had a dozen files inside:


But, after having selected, at random, a few drivers, and having none of them work to find the operating system, I gave up on this "Repair" approach, once and for all, and, I simply re-installed Windows 7, this time with only a single hard disk in the laptop.



m
0
l
a b D Laptop
August 19, 2013 10:08:07 AM

I would have the drives setup as RAID/AHCI in bios.

Since laptop is based on Intel 965 mobile chipset, to see HDD's properly in setup, you need the F6 RST drivers, to load.

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y...

What I would do is use Microsoft USB/DVD Tool to copy your W7 DVD to USB, then extract the drivers to a folder on the us, then boot off the USB and when you get to the point where you select a hdd, use the option to load the drivers.
m
0
l
!