New Build is Failing, Black Screen, Fans on, LED's on, No beeps from speaker

If you have the patience to help a frustrated newbie out. Then thank you, cuz this is gonna be a long post.

Okay so I received all my components yesterday, and after an excruciating, long night of sweating and cussing I believe I've narrowed down the faults of my new build.

New Build
Motherboard-ASRock Z75 Pro3
Processor-Intel i5 3350p (no IGP)
RAM-2X4 GB GDDR3-1333 Mushkin Silverline
GPU-Sapphire HD Radeon 6770 1GB
HDD-Seagate-Barracuda 500GB SATA 6GB/s
PSU-Corsair CX 430 V2

Basically as described by the title above, after I first plugged in all of these components of my new build i get a black screen, but whats really bad, is that my speaker doesn't give any beep codes.

Here's a list of what I've tried so far. (I also read and followed the sticky post..."read before posting about blackscreens")
1. Reseated everything (except CPU and CPU Fan Cooler)
2. Checked if all power chords are properly plugged in (including the 8 pin ATX CPU)
3. Cleared CMOS
4.Individually checked each stick of mushkin ram I got in every ram slot
5.Most importantly i've tried different combinations of components to see if anything works.
-I've booted with just the mobo, cpu, psu, and ram. [Result] No beeps. Blackscreen
-I've booted with everything including GPU. [Result] No beeps. Blackscreen.
-I've booted with everything except RAM, and HDD. [Result] No beeps. Still Blackscreen.
6. And Finally!! To check and see if the speaker itself is broken, which would explain why my new build isnt sending me any beep codes at all. I put the new speaker in my old computer. And the speaker works there. It sends all the proper error codes.

FINAL ANALYSIS- It must be the motherboard....right??

I've done a lot of troubleshooting, tried every combination of components in my new system, and absolutely nothing is working. And im not receiving any beep codes from the mobo to tell me what's wrong. Yet my old computer (which i tested only using its motherboard, cpu, and ram) sends me all of the proper beep codes through the speaker that I just got.

So I have to ask you ppl, the experts, do you think I received faulty motherboard from newegg and I should return it immediately? Or is it possible that I missed something important, or did something wrong?

-thank you if you actually read this. :P

UPDATE-I also must add that the PSU, GPU, and HDD of my new build was taken from my old build. I can confirm that they all work fine, since I just used them yesterday before i swapped the components into the case. The HDD however has not been reformatted for this new build. I dont think that it could be a problem since I've tried booting without it installed and the same blackscreen problem persists.
5 answers Last reply Best Answer
More about build failing black screen fans led beeps speaker
  1. Best answer
    well its look like they have some issues with this motherboard with the memory and the cpu socket...

    try to put your memory in other slot to see if it working and if not working after .... try to remove your cpu and reinstall it
    let me know
  2. badboyrog said:
    well its look like they have some issues with this motherboard with the memory and the cpu socket...

    try to put your memory in other slot to see if it working and if not working after .... try to remove your cpu and reinstall it
    let me know

    Anonymous said:
    Could be either the motherboard needs a bios update to support ivy bridge cpu,

    or that the motherboard needs to boot with a CPU with integrated graphics in order to configure it to use the dedicated graphics card.

    Do you by chance have another 1155 slot cpu?

    A bios update? It says on the ASRock website that the mobo is compatible with the 3350p but it requires discrete graphics which I have been using.

    However i just discovered that the mobo is not compatible with any versions of mushkin ram. So I think I may have found one problem. However that still doesnt explain why my speaker isn't sending any beep codes from my mobo...

    Okay I'll try reinstalling my cpu
  3. @badboyrog
    Okay I've made some progress!
    I reinstalled the cpu as you asked, and the speaker now gives me a 3 beep code. Which according to my mobo manual means there is no RAM in my comp. I dont have any RAM installed as mushkin is incompatible so i'll let you know when I get some new ram today.
  4. ''Note1: It is recommended to install a memory module in DDR3_A2 or DDR3_B2 slot first!
    Note2: 4PCS = dual channel, supports 2 modules and 4 modules
    Note3: 2PCS = tested successfully with 2 modules
    Note4: The O.C. mode is not guaranteed. It depends on whole system configuration and other parameters.
    Note5: For system stability, use more efficient memory cooling system to support a full memory load (4 DIMMs) when overclocking.
    Note6:Due to the configuration of CPU, the default speeds of DDR3 2333/2300 MHz will operate at DDR3 2200/2200 MHz.''

    for your information about your motherboard

    and this link..
  5. Its working! Thanks badboyrog! Im so stupid i forgot that you have to put the cpu fan so that the cpu fan wire is closest to the cpu fan_1 mobo connector. I had it the opposite way reinstalling it did the trick and now im installing windows 7 right now.
Ask a new question

Read More

Speakers LED Monitor Components New Build