Sign in with
Sign up | Sign in
Your question

Asus Z87 Sabertooth Booting problems

Last response: in Motherboards
Share
August 17, 2013 3:17:51 AM

Hello everyone,

I bought an Asus Z87 Sabertooth mb along with a Intel i5 CPU one week ago. Although I managed to install a new OS, the booting problems have been appeared from the very beginning. I was restarting 2-3 times before pc was going to booting stage but for last 2 days it's not booting at all. When I push the power button, motherboard gives random red lights every time. Some times it gives CPU led, sometimes VGA error. Can you please help on this issue?

My rig:

Asus Z87 Sabertooth MB
Intel I5 4670k CPU
Asus 660ti TOP VGA
Kingston 2x4 GB 1600 MHz Ram
Corsair GS 600 psu
Seagate 1TB HDD
a c 150 Ĉ ASUS
a c 114 à CPUs
a c 559 V Motherboard
August 17, 2013 6:49:42 AM

I would firstly try borrowing a power supply, for testing.
m
0
l
August 17, 2013 12:57:36 PM

werner123 said:
Hi, test with another PSU like alexoiu suggested. Also make sure that all power connectors are properly connected, 8-pin CPU / 2x6-pin PCI-E (Graphics card) / 24-pin ATX etc. Clear the CMOS, and remember to reload the Optimized defaults in the bios after clearing the CMOS. See what happens when booting with only 1 memory module installed. Make sure the CPU Heatsink is properly installed to eliminate overheating issues.


I tried another psu but there is no improvement. I also tried booting with only 1 memory module installed, but same issues are on going :(  I dont think PSU or the other hardware causing the booting issues cause in the first 2 days i was able to use my computer and i also managed to install and use Windows 8. But computer started to fail while booting gradually.
m
0
l
!