ASUS Z87 PRO Motherboard VGA LED on, no POST

Hi Guys, New Builder here.

I recently bought a Z83 pro motherboardnand set it up with all of my components. When I turn it on, three LED's are supposed to flash, the VGA, CPU and RAM, then turn off. Instead, the CPU and RAM lights flash, and then the VGA light turns on and stays on. I've followed all the steps in the guide on here, and ascertained that either the motherboard is faulty, or I'm doing something wrong. I've tested all the components in another build, and they work fine. It also won't let me flash the bios.

ASUS z87 PRO motherhoard
Intel i5 4670k CPU
Corsair Dominator 8gb RAM (2x4)
Corsair 750W PSU
Corsair H80i Cooler
Seagate 1tb HDD
MSI GTX 610

(I'm using this GPU just to get it running, and then getting a 670)

Anyone experiencing similar problems with a solution? Or am I going to have to return it and get a Maximus VI? Any help would be greatly appreciated :D
17 answers Last reply
More about asus z87 pro motherboard vga led post
  1. Have you tested the board outside the case?
    Can't you test with the onboard graphics (removing the GPU)?
  2. I've tested it outside the case, and with the onboard gpu, with everything replaced from a different build and nothings working, no changes. Tested different PCI ports too, no difference.
  3. What happens when starting the board with single RAM installed, DVD drive, keyboard and mouse?
    Is the CPU fan spinning, what's the led sequence?
    Have you tried clearing the CMOS (unplug the power cord and remove the CMOPS battery for few minutes)?
  4. Slight success, BIOS is flashing now. Need to do it just with the PSU and nothing else, also don't turn it on first. I've tested with ram in different slots, cpu fan is running fine. Cleared the CMOS, LED sequence is CPU and RAM flash, then the VGA LED lights up when RAM is installed, otherwise no VGA light (RAM is fine, tested with other, working ones). No noise. Tested outside the case, with everything.
  5. Weird. Let's hope that the flashback does solve the issue.
  6. It's been a good 20 minutes and the light stopped flashing ages ago, but it hasn't gone off. The manual says to unplug after the light goes off, does it sound like it's finished updating?
  7. Have you connected the USB drive to the designated Flashback port?
    Is the USB FAT formatted and have you renamed the BIOS file?
  8. Yeah, it's connected to the right port. Formatted then put the CAP file on it. Flashed for a few seconds, then a solid green light after using the flashback key. It shouldn't take 30 mins I don't think.
  9. Renamed it to Z87P.CAP ?
  10. I've renamed it, it's just taking ages to update. The manual says it could be improper USB flash drive connection, BIOS file name error or incompatible BIOS file format. I'm using the Windows 7 one, should I be using the DOS one as I haven't installed windows yet?
  11. I've managed to flash the bios now, using the updated DOS file. But the problem is still persisting with the VGA LED :(
  12. Try reseating the CPU. If still the same, I would RMA both motherboard and CPU.
    Check also the CPU socket for bent pins.
  13. I can RMA the board fine, but I don't have the plastic case that the cpu comes in, would that matter? There is what looks like a scratch on one of the CPU's gold pins on the edge, and a slight blemish too. Could this the source of the problem as the CPU light doesn't come on?
  14. Yes, as the CPU is "responsible" for integrated graphics and PCIe slots.
    One or more faulty pins would create issues regarding the "communication" between CPU and motherboard.
    Can you post a picture of the socket?
  15. Thought so, will RMA them both (found the packaging) and get replacements. The Maximus VI Hero should do, I think. Thanks for your help mate.
  16. You're welcome. Good luck!
  17. RMA'd them, and new setup is working(ish). Must have been a faulty motherboard. Thanks for the help.
Ask a new question

Read More

Boot Failure Flash Motherboards LED Monitor VGA