Sign in with
Sign up | Sign in
Your question
Solved

Linux mint 15 with cairo dock not letting windows open. Any idea's?

Last response: in Linux/Free BSD
Share
August 22, 2013 4:37:09 PM

I have just installed linux mint 15 x64. I installed the video drivers for my AMD 7850 video card off of AMD's site and updated mint with cairo dock installed. Now I can't open any windows at all (Terminal, Gimp, Updater etc.). Nothing will open AT ALL. I have no idea what to do and have no other video card sitting around right now (moving). Any idea's?

Best solution

August 22, 2013 6:35:31 PM

I have Ubuntu experience, but not Linux Mint. I have dealt with the Catalyst / FGLRX drivers for my Radeon HD 6850 in Ubuntu (the base of the Linux Mint 15 distribution).

Only thing I can find with googling is that it says openGL may cause problems with some drivers. You could try to disable Cario Dock's use of openGL. How did you install the Graphics Drivers? Did you use Linux Mint's automated system or did you use the versions on AMD's website? I would recommend using AMD's version rather Linux Mint's / Ubuntu's version.

Alternatively, you can try to purge the window managers or restore default settings or change window managers, but I don't have much experience with that and I am not sure to what extent they will help. You should also ask in both Mint and Cario Dock forums to see if they have any additional advice.

For removing Catalyst / FGLRX and restoring open-source drivers in standard Linux Mint 15 based off of Ubuntu::
You should be able to remove the old drivers from a terminal (either ALT+ Control + F1 or F2 or F3 or F4 if they left terminal access using that method). Otherwise, if there is a safe-boot mode in advanced listing directly under Mint under the grub startup (I'm hoping one of these methods are similar to Ubuntu). Otherwise, find some way to access terminal without being in the desktop environment.

Then follow the removal instructions for Catalyst / FGLRX
http://wiki.cchtml.com/index.php/Ubuntu_Raring_Installa...

You won't need this unless part unless you are using Linux Mint Debian Edition (LMDE) (I have no experience with LMDE, but it's based on debian, so the following should work):
Find a way to get to terminal then follow the link
http://wiki.cchtml.com/index.php/Debian#Removing_Cataly...

Once you are using the open source drivers, restart and see if it fixes the issue with cario dock. If it does, you can try using AMD's latest drivers from their website if you want, or just leave it at the default open-source drivers (although you will likely need to disable openGL if you haven't already). Back in Ubuntu 12.10, I used the wiki.cchtml.com's manual install and it worked. I did encounter the Underscan issues mentioned in the help.ubuntu.com, so I'm including the link.
http://wiki.cchtml.com/index.php/Ubuntu_Raring_Installa...
https://help.ubuntu.com/community/BinaryDriverHowto/ATI...

Share
August 22, 2013 8:06:03 PM

Hi. That was really informative! I tried logging off and it won't even log off. The task bar for the default UI barely shows and is acting very buggy. I always install the video drivers of of the AMD website for linux after or before updating (on both Ubuntu and Mint). Every time I try to open anything it says it's open on the dock but it never shows on the desktop. I'll probably have a look around on getting into the boot options menu for Mint or whatever they call it in Mint (not sure).
m
0
l
Related resources
August 22, 2013 9:22:00 PM

I looked it up and it's the recovery mode that I was thinking of. It should right below the option to boot into Mint if you have mutiple operating systems on your computer. Sometimes they hide the Grub2 menu if you only have one operating system installed and holding the shift on the right side of the keyboard can access the menu. You can get to a terminal the recoery mode. If you just want your system stable, you might consider just removing cario dock and it's configuration files for now. Afterward, remove any cairo dock entries from your startup applications (in case you later decide to reinstall cario dock it won't be affected by old setttings).
http://glx-dock.org/ww_page.php?p=Uninstall&lang=en

Do you remember if you ran it with openGL? I see a note in the wiki of
"Run with Cario backend
$ cairo-dock -c
Note: All ATI card owners must use this option when runnning cario-dock." as opposed to the openGL backend.
m
0
l
August 22, 2013 11:06:52 PM

Yes it does have open GL enabled. I'll go try the recovery mode right now and see what happens. I kind of want to keep cairo dock but, can I uninstall it and re-install it aftr everything is fixed?
m
0
l
August 23, 2013 2:14:00 PM

johndan102496 said:
Yes it does have open GL enabled. I'll go try the recovery mode right now and see what happens. I kind of want to keep cairo dock but, can I uninstall it and re-install it aftr everything is fixed?


Yeah, you can re-install it later and set it not to use OpenGL. I suggested doing the purge method to remove any configuration files and also removing it from startup applications before re-installing so a re-install wouldn't default load using OpenGL based on pre-uninstall settings.
m
0
l
!