AMD 13.8 beta, driver / graphic card glitch & can't install 13.4

Hi,

I recently updated from AMD driver 12.xx to 13.8 beta. I choose the 13.8 beta as they have bug fixes for Final Fantasy xiv.
When I press keyboard keys or click with my mouse (especially when changing browser tabs / to different programs / minimizing, etc) and sometimes also just randomly, I get some kind of 'glitch' which is kind of a bar (taking up whole width, only part of the screen height) that shows for a split second some part of the screen at the wrong place. This happens mostly on the bottom of my 2nd (not primary) screen but also on the main screen, also at other positions sometimes. It doesn't happen when I'm in games playing with windowed borderless mode (haven't tried other modes).
So I thought this might just be an issue with the driver and uninstalled by uninstalling the "AMD Catalyst Install Manager" using the Express Mode. After restart I installed 13.4 which requires another restart. When booting with 13.4 freshly insalled I get a BSOD (while the windows symbol is displayed before the login screen) which is displayed for a split second before the computer restarts itself and boots in the Windows start up aid. I used system restore to get my computer booted with 13.8 again.
I tried again by using the AMD cleanup utility to uninstall the program and also by removing recent .Net 4.5 updates which I thought might be involved. Always the same issue.

I also looked for the error log but didn't find anything else then a "critical Kernel-Power error" with event id 41 but no bugcheckcode (0), no bugcheck parameter or any other information.

Does anyone have an idea how I could possibly fix this glitch? Is it a driver issue at all?
I currently see the option to uninstall again and try install an older driver (for example newest 12.xx) but don't really know what else could help and I would prefer to get 13.8 running if possible.

Any assistance / advice is welcome - sorry for the wall of text.

Short system information:
I have an XFX HD 5850 black edition and use MSI Afterburner to control my fan.

Thanks a lot!

Regards
ABBDVD

PS: Don't have a system restore point from before installing 13.8 anymore :S
2 answers Last reply
More about amd beta driver graphic card glitch install
  1. Mousemonkey said:


    Anonymous said:

    I tried again by using the AMD cleanup utility to uninstall the program and also by removing recent .Net 4.5 updates which I thought might be involved. Always the same issue.


    -> Yes I did.

    I also noticed the somewhat strange behavior that when I change from 1 to 2 screens my fan turns to 50%. I then have to go to MSI Afterburner and not change back to 'Auto' or so, but go into the "detailed" profile settings and just click "ok" again. Doesn't happen when changing from 2 to 1 screen.
    Seems really weird...

    I use saved profiles in CCC to change from 1 screen to 2 and back again. Reassigning didn't fix this.
Ask a new question

Read More

Drivers AMD XFX Graphics Installation Error Graphics Cards Radeon