Sign in with
Sign up | Sign in
Your question
Solved

Help with a USB 3.0 Driver issue.

Last response: in Systems
Share
August 24, 2013 12:18:32 AM

So I've been having a problem with my computer in that it won't allow me to install the USB 3.0 Driver without causing a BSOD. I'll try to explain as best I can.

One of my main problems is that when transferring files to USB devices, the green "progress bar" that shows up in the Window, goes all the way to the end, except for about an eighth of an inch, as soon as I start a transfer, and just sits there until the transfer is done. It gives me no estimated time or anything, about how long the transfer will take, which is somewhat annoying. My USB 3.0 devices also don't seem to be taking advantage of the USB 3.0 speeds as they used to.

Another problem is that my Headset (which is a Logitech G930 - Wireless) has a lot of crackling, and other problems dropping in and out, which I feel is most likely being caused by this USB Driver issue, as everything else seems to be in order.

Anyway, here is what happens, I have attempted to download the USB 3.0 Driver directly from the ASUS support site (I have a ASUS P8Z77-V Motherboard), and when I run the install, it gets to the very end, and then my computer BSOD's. Upon restart, I can not get my system to load without doing a System Restore sometime before the point that I installed the driver. I have also tried installing the driver directly from the disc that ASUS included with the motherboard, and the exact same thing happens. It gets to the end and then BSOD's.

In my Device Manager, I see that I have two items that are not finding drivers, "SM Bus Controller", and "Universal Serial Bus (USB) Controller", which I assume both would be covered if I could get this driver installed, however, for some reason, it just won't install.

Thinking maybe it was conflicting with something else I had installed, I did a fresh install of Windows, and right after Windows was done, I popped in the ASUS disc to install drivers, and it gets through all of them, up to USB 3.0 Driver, and then BSOD's at the end, again. I've also tried a different Windows disc, and also a different Windows version (Windows 8.1 Preview, whereas my normal OS is Windows 7) and everything causes the same problem.

Anyway, after spending quite a few hours trying to figure out what the problem could be, does anyone here happen to have any idea? Is it most likely a problem with the motherboard? Could it be the BIOS version that I am using that could cause this problem? I have updated my BIOS once, because it was unstable with the default BIOS it shipped on, when you tried to put your RAM any higher than 1333MHz. Could the BIOS update have caused a problem with the USB 3.0 Driver?

Anyway, I appreciate any help or information that anyone can give. Specs below if needed, thanks!




-----------------------------------------------------

Windows 7 64-bit / Windows 8 Preview 64-bit
Intel Core i7-3770k
EVGA GTX 680
16GB's Corsair Vengeance Pro 1866MHz
Corsair HX750 PSU
ASUS P8Z77-V Motherboard
2x128GB Samsung 840 Pro SSD's
1x128GB Crucial M4 SSD
1x256GB Crucial M4 SSD
1x1TB Western Digital HDD
Blu-Ray Drive
Thor V2 Computer Case

More about : usb driver issue

Best solution

August 24, 2013 12:51:02 AM

ferrari91169

Are you copying to an NTFS formatted drive? If so this is normal behaviour. For some reason NTFS flash drives seem incapable of properly transmitting their transfer rate or whatever.
Share
August 24, 2013 1:31:16 AM

teh_gerbil said:
ferrari91169

Are you copying to an NTFS formatted drive? If so this is normal behaviour. For some reason NTFS flash drives seem incapable of properly transmitting their transfer rate or whatever.


Really? I never noticed the problem in the past when using NTFS formatted flash-drives, but yes, the drive is NTFS.

One more thing I wanted to note, while my USB 3.0 Ports do seem to work fine with USB 2.0 equipment, they will not work with my USB 3.0 enabled devices, such as my USB 3.0 flash drive, or USB 3.0 External Hard Drive. However, my USB 3.0 items will work in the USB 2.0 slots.
m
0
l
!