Sign in with
Sign up | Sign in
Your question

HD 7850 not recognised as a video card.

Last response: in Graphics & Displays
Share
August 24, 2013 3:54:55 AM

There are several other threads related to issues with 7850 not being recognized however i really just want some advice specific to my issue.

I have bought a new Powercolor HD 7850 GPU as well as a new motherboard (Asus M5A78L-M/USB3). I have insured it is properly inserted into the PCI-e slot as well as connecting a 6 pin pci power cable.

The Problem is however that it is not recognized at all in device manager.

I have updated the BIOS to the latest version as well as install the graphics drivers.

Other threads put the issue down to insufficient power, however I have checked and the PSU is 550 W (coolermaster RP-550-PCAR).

Importantly my monitor is plugged into the Graphics card and the monitor shows the proper display.

Any help would be greatly appreciated.


Ok. I have now tried a full uninstall of graphics drivers and reinstall with no luck.

I put my old graphics card in and it was recognized immediately. - so not a slot problem. (old graphics card is HD 4850 toxic).

Thanks again
August 24, 2013 9:51:50 PM

Disabled the onboard graphics. Did nothing, still able to use 1920 x 1080. Have tried rolling back to an older bios & reinstalling the motherboard drivers.

Is this a windows issue? Im going to try the card in another PC and then reinstall windows.
m
0
l
August 26, 2013 6:15:27 PM

There is nothing wrong with the card, runs perfectly in by brothers pc.

This leads me to 3 conclusions

The 12V1 pin is not powerful enough (16 x12 = 192 W), where my brother has (20 x 12 = 240 W). Would this lead to the device not being recognized at all?

Its a windows/diver issue that can be solved by reinstalling windows.

The GPU and Mobo are incompatible.
m
0
l
August 27, 2013 2:46:19 AM

I have solved the issue, and although this was nothing more than a monologue I will post my solution for any others with this problem.

As i should have known it was a driver issue, The card came up as 'standard VGA adapter' (which i origonally mistook for the onboard). Although i had uninstalled and reinstalled the corect drivers (several times) the catalyst instal manager is useless and did not properly install the drivers.

I went into device manager and pressed update driver. I then manually chose the correct file under :C\AMD\Support. (note, not the downloaded file).

This properly installed the drivers and now its working like a dream.

If anyone ever has a similar problem send me a message and i will do all I can to help.
m
0
l
!