Solved

PC doesn't shows boot info, BIOS, energy star, splash screen... straight to Windows

My PC doesn't show anything at all during the boot process. No boot info, BIOS, energy star, splash screen, nothing... My monitors are in a state is sleep until the Windows 7 "Welcome" screen shows up, then they click on. I hadn't thought much about it in the past but now I'd like to reinstall Windows and I can't access the boot setup. I have no doubt that these tasks are being completed, it's just that I can't see them. I used to be able to some time ago... What's going on?

Windows 7
gigabyte z68xp-ud3
Intel 2500-K
GeForce GTX 550ti
6 answers Last reply Best Answer
More about shows boot info bios energy star splash screen straight windows
  1. Best answer
    they come up, you just aren't seeing them. hit the bios key once the system is powered on, usually either "del" or "f2". i usually just smash both of them, worst comes to worst you'll get a keyboard error prompt and that will get you into bios anyways.
  2. daswilhelm said:
    they come up, you just aren't seeing them. hit the bios key once the system is powered on, usually either "del" or "f2". i usually just smash both of them, worst comes to worst you'll get a keyboard error prompt and that will get you into bios anyways.


    I tried pounding the Delete key over and over during the boot to get some response (tried that before posting). It must have done something because Windows never came up. Nothing ever appeared on the screen however. I had to manually restart to get the PC to boot.
  3. I'm getting the same situation, Any insight?

    --->

    I fixed mine by removing the BIOS battery on the motherboard and replacing it (resetting the BIOS)
    Hope this works for you too.
  4. Fixed. I have two graphics cards. I had my monitors plugged in to the secondary one, not the primary.
  5. glad you got it worked out
  6. Sam Graves said:
    Fixed. I have two graphics cards. I had my monitors plugged in to the secondary one, not the primary.

    Dude! I had a similar problem, and also my desktop was frozen. I didn't think of using my primary card, I had forgotten I was plugged into my secondary! I did the swap and it worked! Sometimes you just need to try everything.
Ask a new question

Read More

Windows Boot BIOS Motherboards Windows 7 Splash Screen