Sign in with
Sign up | Sign in
Your question
Solved

Certain Blu Rays no longer play Windows 7 64bit.

Last response: in Windows 7
Share
August 27, 2013 7:41:29 AM

I've used Cyberlink PowerDVD12 Ultra, and it was playing every film fine for the longest time, but months later after not having watched any... all of a sudden... my Dredd would not load.

I setup WinDVD Pro 11... and same thing. Stargate and other Blu Rays play no problem, but Dredd will not. The system reads the disc contents... they're available in Windows Explorer, but the players will just no longer play it. The back of the disc is impeccable. It's my most valued disc. It has a bundled digital copy, and you can see by looking under the disc that there're waves almost like a polarization in the disc. This seems to be common with certain Blu Rays. It's Blu Rays with this format that are no longer able to play.

If they were once able to... and no longer... than without reproach this is something to do with an update. I've tried researching what it might be and organizing updates by date with no such luck. I've decided to make a first post on Tom's Hardware.

I would appreciate any assistance.

Windows 7 Ultimate 64bit
Pioneer 2208 Blu Ray & BDXL
GTX 460 Gigabyte
16GB Ram
Core i7 Z77 Asus mobo
Mushkin SSD

Flawless operation outside of this one issue.

Transferred to forum: Windows 7, excessive tags removed. - G

Best solution

a b $ Windows 7
August 27, 2013 7:53:47 AM

I've had a similar situation recently (using PowerDVD9).

In my case, there was an update that needed to run (like you, Blu-Rays that previously played fine, were no longer working). The update program opens an Internet Explorer windows that is supposed to start the download/install process. However, I found out the URL extension that CyberLink encoded into their updater is incorrect.

Just as an example:

Incorrect Extension --> http://www.tomshardware.com/answers/id-1781698/blu-rays....htlm
Correct Extension --> http://www.tomshardware.com/answers/id-1781698/blu-rays....html

With my issue, the problem was an extra letter on the URL extension on the updater web page. Rather than just ending in ".JSP", it was coded as ".JSPP". I removed the second "P" from the URL and the updater ran without further issue and I can now watch all my Blu-Ray discs again.

Hope this helps.

-Wolf sends

Edit: The ".JSP" extension is normally followed by a number of variables, so you'll actually have to find the extension in the middle of the URL.
Share
a b $ Windows 7
August 27, 2013 9:34:33 AM

Have you tried checking the disc for fingerprints and scratches? Sometimes a bit of dust or fog on the disc can distort playback.
m
0
l
Related resources
August 27, 2013 5:50:19 PM

Yes @g-unit, the disc is flawless. I've held that thing on a shrine practically. It's my favorite one.

and, @Wolfshadow in this case, the blu ray had been playing flawlessly, and is no longer... so I could only see an update causing damage, not being required. I may be wrong? The only updates my system has had were windows related, so I'm a bit upside down about it. The drive has no software that comes with it. It's full-on plug and play, shows up model for model in device manager, no firmware from manufacturer.

Anyone have any info regarding perhaps C++ versions? .Net Framework? Any Windows updates? Other threads I've encountered have the potential culprit floating around February 2013 as the update time frame that screwed up their setups similarly.
m
0
l
a b $ Windows 7
August 27, 2013 6:26:41 PM

I think you misunderstood me. I had a number of Blu-Ray discs (Avatar, Lord of the Rings) also previously playing flawlessly. When an update to my PowerDVD9 software was required, and I installed one of those discs, I got a message stating an update was required to continue playing. Only after figuring out the error in the updater software and updating PowerDVD9 successfully was I able to get my discs working again.

If you insert a blu-ray disc and PowerDVD just seems to sit there doing nothing, minimize the PowerDVD window and see if there is a Required Update message. If there is, click OK. If it opens Windows Internet Explorer and that web page errors out, see my solution above.

-Wolf sends
m
0
l
!