Solved

All games freeze, continues with lag

All the games I have will freeze after a while in-game for a while, then it continues with lag. Oddly, the sound continues to play while it's frozen (meaning the game still continues) but nothing moves. Oddly I'm still able to go into desktop or the start screen while this happens, and usually open task manager to kill the game. This happens with all the games I've tried with so far, which is DmC, Dead Island, and Dota 2. Happens much faster in DmC and Dead Island.

Here are the specs for my desktop:
- Motherboard: Gigabyte 970A-DS3
- CPU: AMD FX-4300
- GPU: ASUS AMD Radeon HD7770 DirectCU TOP 1GB GDDR5 1120MHz Overclocked
- RAM: Corsair Vengeance LP 8GB
- PSU: Silverstone ST60F-ES
- OS: Windows 8 Pro 64-bit

Bought it in March 2013 so if it's a hardware problem I'd wanna send it in while it's still under warranty.

UPDATE:
Added PSU and RAM info.

I forgot to attach this earlier, here's a scan using HWMonitor. Do you guys think it's overheating or something?

16 answers Last reply Best Answer
More about games freeze continues lag
  1. Test your RAM using Memtest86+. Make sure you've got the latest drivers installed for your mobo, particularly sound, and for your graphics card. What is the brand and model (not just wattage) of the PSU?
  2. could be a driver issue, grab the latest amd beta drivers and driver fusion.

    uninstall current driver and dont restart.
    run driver fusion amd driver cleaner.
    install latest drivers as custom and only install display and hdmi driver.

    see if this helps at all.
  3. Onus said:
    Test your RAM using Memtest86+. Make sure you've got the latest drivers installed for your mobo, particularly sound, and for your graphics card. What is the brand and model (not just wattage) of the PSU?


    All drivers are updated, I'll try doing Memtest tomorrow. And I don't exactly remember the model of my PSU so I'm gonna have to check that, I do remember it's a SilverStone though.

    mauller07 said:
    could be a driver issue, grab the latest amd beta drivers and driver fusion.

    uninstall current driver and dont restart.
    run driver fusion amd driver cleaner.
    install latest drivers as custom and only install display and hdmi driver.

    see if this helps at all.


    Did that, problem is if I don't restart there was an error, some file was missing. (INF file? something like that).
    So I completely uninstalled all my AMD drivers, restarted and installed the latest ones. Problem still happening.
  4. Hmmm, most Silverstone PSUs are decent. Let's see what the Memtest says...
  5. I suspect the CPU is not running as it should based on the 16-30W reading run CPUz and see what it shows.
  6. simon12 said:
    I suspect the CPU is not running as it should based on the 16-30W reading run CPUz and see what it shows.


    Here you go.




    Onus said:
    Hmmm, most Silverstone PSUs are decent. Let's see what the Memtest says...


    My PSU is a SilverStone ST60F-ES. Still no time to do memtest as of yet. Should I do a full 7 cycles?
  7. Something is not right there with the multiplier at 7, have you overclocked or messed with the CPU settings in the bios at all? I suggest you reset the bios or update it to the latest version. According to Gigabyte the board only supports the CPU with bios version F6 if yours is older then it needs updating and is likely the cause of the problem.
  8. simon12 said:
    Something is not right there with the multiplier at 7, have you overclocked or messed with the CPU settings in the bios at all? I suggest you reset the bios or update it to the latest version. According to Gigabyte the board only supports the CPU with bios version F6 if yours is older then it needs updating and is likely the cause of the problem.


    I haven't done any tweaking with the BIOS at all, or overclocking, and I'm pretty sure it's up to date. I just checked with @BIOS last night. What should the multiplier be though? Sorry my knowledge on this stuff is prettyyyy limited.

    How do I know what version my BIOS is? I checked using MSInfo32 and at BIOS Version/Date it says American Megatrends Inc. FD, 1/23/2013.
  9. Sorry I just checked and the CPU does have a low power state with 7 as the multiplier. CPUz gives the bios version under the mainboard tab.
  10. simon12 said:
    Sorry I just checked and the CPU does have a low power state with 7 as the multiplier. CPUz gives the bios version under the mainboard tab.


    According to CPU-Z my BIOS version is FD.



  11. OK try looking in the bios for the version
  12. remove the overclock from your gpu using msi afterburner, clock it back down to 1000mhz and see if it still freezes, the overclock on the card could be unstable even if its factory for the chip on it.
  13. mauller07 said:
    remove the overclock from your gpu using msi afterburner, clock it back down to 1000mhz and see if it still freezes, the overclock on the card could be unstable even if its factory for the chip on it.


    IT WORKED! Well at least I think so.
    I used AMD Vision, went to AMD Overdrive, configured graphics, and set both GPU clock settings and memory clock settings to 1000Mhz (they were at 1170 and 1150 respectively). Although I'm not really sure if that's recommended. Really have no experience with overclocking whatsoever.

    I played DmC and fought the last boss for around 5 rounds and the problem didn't happen (normally it would happen after 1 round) so I THINK this solved it. I'll try more games later and see what happens.
  14. so did you overclock the card yourself or was it a factory overclock?
  15. mauller07 said:
    so did you overclock the card yourself or was it a factory overclock?


    It was a factory overclock. Like I said, no experience with overclocking at all haha. Is 1000Mhz for both GPU and memory clock a good value?
  16. Best answer
    try 1100 on the core and leave the memory how it was and see if its stable, if not just slowly decrease the memory and then the core untill its stable by 20mhz at a time.

    seems like its an unstable factory overclock then.
Ask a new question

Read More

Desktops Games Lag Video Games