Sign in with
Sign up | Sign in
Your question
Solved

WD External Hard Drive Usb 3.0 randomly disconnecting and very slow transfer rate

Last response: in Storage
Share
August 28, 2013 8:41:49 AM

I have 2 Hard Drives. WD and Seagate both 1 TB.

Questions:

1. RANDOMLY DISCONNECTS

I am transfering a lot of large files from WD to Seagate. In the process of transferring WD gets disconnected. (I am not sure if it gets disconnected or it randomly locks since it has WD Smartware). WHen this happens I can hear the disconnect ping sound and WD would give me an autoplay screen. So I unlock it again and the cycle continues..

I have tried disabling the locker but same thing happens. I've tried different ports and connectors and different pc's as well. Same thing happens. I do not know what is causing it to disconnect at random times. It's beginning to get inconvenient because when I transfer large files and it gets interrupted, I start all over again. Can someone please tell me?


2. SLOW TRANSFER RATE

When I transfer files from computer's internal drive to WD & Seagate and vice versa, the speed is fast.

When I transfer from Seagate to WD. Still fast.

But when I transfer from WD to Seagate, 1 GB would take 15 minutes to complete the transfer process. Why is this happening?

I tried tweaking it in Control Panel fro better performance, tried different ports, connectors and pc's.


*All answers will be greatly appreciated. I am desperate to know the solution. I am worried my WD might be defective since i just got it today.
August 28, 2013 10:05:58 AM

Well I had the same issue with my WD 1Tb My passport. Problem was very frequent in XP. Then defragemented and used in Win7 for 2 days and no issue.After my mobo gone down and my new system is now ubuntu.In ubuntu no problem arrised. Cant say if OS are an issue. However error checke and defrags may solve your problem.
m
0
l
a b G Storage
August 28, 2013 1:53:04 PM

If you're trying it on a desktop, be sure you're using the ports on the back of the PC.
m
0
l

Best solution

September 25, 2013 5:51:35 AM

I had a similar problem with a brand new WD 2TB drive. The solution... it shipped with a bad USB3 cable :-( I had purchased two identical drives (December 2012) and one was doing the disconnect thing you describe. At one point, I switched drives/cables and the problem came up on the second drive whereas the first one now worked fine. I had a third USB3 cable and ran multiple tests - the drives were OK (and still are!) but the cable was junk. Hope this info helps.
Share
!