Sign in with
Sign up | Sign in
Your question
Solved

Can't get preinstall ACHI SATA driver to load with Win 8 and Gigabyte GA-F2A85XM-D3H

Last response: in Motherboards
Share
August 29, 2013 9:33:30 PM

New rig, can't get Windows 8 to install - stuck at ACHI SATA driver preload:

Gigabyte GA-F2A85XM-D3H flashed to newest BIOS Ver : F4b
AMD A10-6800K APU
Corsair DDR III 8g (2x4g)
Have tried two brand new hard drives a) Samsung pro 840 128G SSD and b) Seagate Sata 6.0 500g
Win 8 Pro OEM

Trying to do fresh install of Windows 8 on newly built machine. Created bootable USB Win 8 install from .iso (machine is mini box with no DVD drive). Windows starts install then indicates "A media driver your computer needs is missing..." -

Downloaded AMD AHCI pre-install driver to another USB from Gigabyte site which I can browse to no problem from within the Win 8 installer to \w8_ahci\w864a\amd_sata.inf and highlight/click next, Win 8 tries to install the driver, wheel spins and progress bar fills several times then stops and says "No new devices were found. Make sure the installation media contains the correct drivers, and then click OK". Installation will not proceed.

Have also tried downloading achi sata driver directly from AMD site and trying to pre-load with same result.

Here's where it gets odd. Go into bios and change SATA from ACHI to legacy IDE thinking it should load no problem yet upon start, Win 8 installer gives same "A media driver.." GAH! There's clearly no IDE preload driver. Tried moving the SATA to different ports, tried different HDD, no luck.

Decided to rule out bad MOBO so ran Unbutu 13 and it installs to disk just fine, boots right up and is ready to roll.

Why can't I get the pre-load driver to work on this box? Should I try Win 7 instead?

Any help appreciated!

More about : preinstall achi sata driver load win gigabyte f2a85xm d3h

a c 325 V Motherboard
August 29, 2013 9:51:19 PM

Point the installer to the w864a folder, not the amd_sata.inf.
m
0
l
August 30, 2013 8:47:17 AM

Calvin7 said:
Point the installer to the w864a folder, not the amd_sata.inf.


I should be been clearer, I navigated to the \w864a\ folder and Win 8 scanned and provided the list to choose from which I did and it tried to install then fails with "no device found". If you uncheck "hide drivers that aren't compatible" you see all the drivers in that folder. I've tried them all to no avail.
m
0
l
Related resources

Best solution

August 30, 2013 10:33:32 AM

At GB tech support's suggestion, I attached a SATA DVD and tried install from Win 8 DVD. Low and behold it loaded the AHCI driver no problem and installed just fine. SO moral of the story, if you are trying to load your OS from a USB key and running into problems, try from the DVD instead.
Share
August 10, 2014 7:43:41 AM

Eric Wollard said:
At GB tech support's suggestion, I attached a SATA DVD and tried install from Win 8 DVD. Low and behold it loaded the AHCI driver no problem and installed just fine. SO moral of the story, if you are trying to load your OS from a USB key and running into problems, try from the DVD instead.


I am havig the same problem as Eric, and I am trying from a Windows 8.1 64bits DVD. So no, the problem isn't in the USB installer.
m
0
l
September 11, 2014 12:04:38 PM

Problem salved: apparently it was caused by a bad disk. Installed perfectly from a USB driver.
m
0
l
!