Vid Card and USB Ports not working (New Build)

Good morning community,

I'm in the process of building my new system. Specs are:

Intel i7 3930k
Asus Rampage IV Extreme MB
Galaxy GeForce GTX 780 HOF
Gskill ripjaw X Series 2x8GB Ram
Coolermaster 800W PSU, etc

I've got everything installed and tried powering it on this morning. Everything powers on (case fans, mb, cpu cooler, vid card) but I get no video to my monitor and none of the usb ports are working. That includes the mb usb ports as well as the case usb ports. At the moment, I'm at a loss. Any assistance you can provide in narrowing down this issue would be greatly appreciated. Thank you.
1 answer Last reply Best Answer
More about vid card usb ports working build
  1. Best answer
    This machine probably isn't POSTing, if you aren't getting video. Test the CAPSLOCK on the keyboard to see if it responds. Typically when there is a CPU fault and the system won't POST, the keyboard won't respond properly. Most likely culprit is a bent pin on the CPU socket.

    Failing that, strip the machine to the bare essentials; Mainboard, CPU, 1 stick of RAM (read manual for where to place RAM), PSU, and video card if it doesn't have onboard video(monitor and keyboard too of course). No mouse, HDDs, optical drives, or anything else to get in the way of your diagnosis. You need this to POST before you can go any further. Listen for successful POST beep, and or watch system codes if the mainboard has a LED readout. If it does POST with those basic components, start adding 1 item at a time till it no longer POSTs.
Ask a new question

Read More

New Build USB Systems