Sign in with
Sign up | Sign in
Your question

Newly upgraded PC randomly freezes and my screen looks possesed and i have to restart

Last response: in Systems
Share
September 1, 2013 6:34:56 PM

Recently i had upgraded my PC which was a Phenom chipset to lga 1150 with an intel i-5 4670K haswell 4th gen processor and using the integrated intel HD graphics 4600. Im using a gigabyte Z87M-D3H motherboard a micro ATX lga 1150. When i first installed these upgrades my computer started randomly freezing and my screen looks like it has been possesed and my mouse and keyboard stop working as in i have light up keyboard and mouse and all their LED's shut off and is not responding at all. I HAVE NO IDEA WHAT IS CAUSING THIS. If you guys could even provide a slight clue it would be greatly appreciated and if you would like further info towards my PC if it would help im not sure.
What my screen looks like when it freezes http://imgur.com/rHwgcxk
P.S i also installed a - Corsair H60 water cooling system
- added 8gb of extra ram Kingston hyper x (now currently running 12 gb of total RAM)
Related resources
September 1, 2013 7:20:14 PM

You should be good (psu wise). Did you think about a video card? You might be overwhelming the hd4600.
m
0
l
September 1, 2013 11:33:54 PM

ur6beersaway said:
You should be good (psu wise). Did you think about a video card? You might be overwhelming the hd4600.


My graphics card which is an HD gigabyte 5770 broke and sent it in for an RMA with gigabyte so still waiting on that
m
0
l
February 16, 2014 4:04:16 AM

imbrown2 said:
Recently i had upgraded my PC which was a Phenom chipset to lga 1150 with an intel i-5 4670K haswell 4th gen processor and using the integrated intel HD graphics 4600. Im using a gigabyte Z87M-D3H motherboard a micro ATX lga 1150. When i first installed these upgrades my computer started randomly freezing and my screen looks like it has been possesed and my mouse and keyboard stop working as in i have light up keyboard and mouse and all their LED's shut off and is not responding at all. I HAVE NO IDEA WHAT IS CAUSING THIS. If you guys could even provide a slight clue it would be greatly appreciated and if you would like further info towards my PC if it would help im not sure.
What my screen looks like when it freezes http://imgur.com/rHwgcxk
P.S i also installed a - Corsair H60 water cooling system
- added 8gb of extra ram Kingston hyper x (now currently running 12 gb of total RAM)


I'm having EXACTLY this issue as well! Did you ever find a way to solve it?
m
0
l
!