Help with Using RIP between two Cisco 1941s

soundtech85

Honorable
Sep 4, 2012
10
0
10,510
Hello!

I have am a systems administrator and our networking guy left so I get to have fun with cisco products now. I have setup a few test environments to work with switches and routers. Currently I'm having an issue getting RIP to work between two 1941 routers. I figured out how to setup static routes and they work fine, but never was able to get RIP working.

I should also ask if this is purpose of RIP. I know they are suppose to tell all the routers of other network paths/etc, but I assumed if you hooked up two routers physically and put them on different networks and enabled rip and told them what networks to advertise to that it would create a route for you. Is that the case even or am I way off course?

My configuraton is as such:
R1(named booccrttest): int gi0/0 10.45.10.2/24
R2(named booccrttest2) int gi0/0 10.46.10.2/24


I am going to post the show run/show ip route from the routers:
R1:
interface GigabitEthernet0/0
ip address 10.45.10.2 255.255.255.0
duplex auto
speed auto
no mop enabled
!
!
interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
!
interface Serial0/0/0
no ip address
shutdown
no clock rate 2000000
!
!
interface Serial0/1/0
no ip address
shutdown
no clock rate 2000000
!
!
router rip
version 2
network 10.0.0.0
network 192.168.0.0
neighbor 10.46.10.2
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip default-network 10.46.10.0
ip route 10.46.10.0 255.255.255.0 GigabitEthernet0/0 10.46.10.2
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password 0n10n
login
!
scheduler allocate 20000 1000
end

booccrttest#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route


Gateway of last resort is not set


10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
S 10.0.0.0/8 [1/0] via 10.46.10.0
C 10.45.10.0/24 is directly connected, GigabitEthernet0/0
L 10.45.10.2/32 is directly connected, GigabitEthernet0/0
S 10.46.10.0/24 [1/0] via 10.46.10.2, GigabitEthernet0/0

R2:
interface GigabitEthernet0/0
ip address 10.46.10.2 255.255.255.0
duplex auto
speed auto
no mop enabled
!
!
interface GigabitEthernet0/1
ip address 10.45.10.3 255.255.255.0
shutdown
duplex auto
speed auto
!
!
interface Serial0/0/0
no ip address
shutdown
no clock rate 2000000
!
!
router rip
version 2
network 10.0.0.0
neighbor 10.45.10.2
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip default-network 10.45.10.0
ip route 10.45.10.0 255.255.255.0 GigabitEthernet0/0 10.45.10.2
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password 0n10n
login
!
scheduler allocate 20000 1000
end

booccrttest2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route


Gateway of last resort is not set


10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
S 10.0.0.0/8 [1/0] via 10.45.10.0
S 10.45.10.0/24 [1/0] via 10.45.10.2, GigabitEthernet0/0
C 10.46.10.0/24 is directly connected, GigabitEthernet0/0
L 10.46.10.2/32 is directly connected, GigabitEthernet0/0


Now I had about the same setup prior to doing the static routes minus the static routes and nothing showed up for rip.
I did look at the debug ip rip command as well and this is what showed up from R2:

*Sep 6 20:05:59.426: RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/0 (10.46.10.2)
*Sep 6 20:05:59.426: RIP: build update entries - suppressing null update
*Sep 6 20:05:59.426: RIP: sending v2 update to 10.45.10.2 via GigabitEthernet0/0 (10.46.10.2)
*Sep 6 20:05:59.426: RIP: build update entries - suppressing null update

I'm hoping I'm just making a dumb mistake here. Can anyone please help me? Thanks!
 
Solution
RIP will share its directly connected routes ONLY if these networks have been declared under rip configuration with the "network" command, so it should be working since we declared their respective networks (the network connecting both routers has to be declared as well so rip connection is established).

I've copied your configs into two routers and managed successfully to have RIP working, R1 learned about network 10.46.10.x/24 while R2 learned about network 192.168.0.x/24

So if you want, backup your current configs, clear both routers and apply the following:

Router R1:

hostname R1
!
!
!
!
interface GigabitEthernet0/0
ip address 10.45.10.2 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip...
Yes, RIP being a routing protocol it's designed to advertise the routes it has declared on itself or learned from other devices to other devices as well.

removing your static routes should allow RIP to show the routes, entries might be being suppressed because your both routers already know how to reach them through a "more reliable" route, being the static routes you made.

If still doesn't work then:

Gotta admit I've never used the neighbor command when configuring RIP, so even though i'm not sure what it does, I can assure you you don't need it to have RIP working, so try removing it on both routers.

Then, since R2 has 2 networks under the range 10.x.x.x/24, the command no auto-summary is required under the rip configuration as follows:

R2#configure terminal
R2(config)#router rip
R2(config)#no auto-summary

You can apply it to R1 also if you want to.



and that should do it.



 

soundtech85

Honorable
Sep 4, 2012
10
0
10,510

First, thank you for your reply RadiKat! I didn't know about the autosummary command. Essentially making it able to do classless routing.

So... next what I did was I took off the static routes and the neighbor commands. Added the autosummary for both routers. The routers are directly connected through the gigabit ports. Rip is still on version 2 with the networks to advertise advertised.

Still nothing is working however. Since RIP is intended to advertise routes to other routers that it knows and share the wealth persay, i'm wondering if it is supposed to share its directly connected routes to other routers using rip? If not then that would make complete sense why it "isn't working" because it doesn't work that way. If you just connect two routers together without any static routes and enable rip is it supposed to create a route between routers?

If anyone can verify this question for me, then i will know if i'm on the right track or not.

so just assume you have r1 and r2. They are connected through gigabit ports on diifferent networks and you enable rip version 2. Will this create a route?

Thanks!
 
RIP will share its directly connected routes ONLY if these networks have been declared under rip configuration with the "network" command, so it should be working since we declared their respective networks (the network connecting both routers has to be declared as well so rip connection is established).

I've copied your configs into two routers and managed successfully to have RIP working, R1 learned about network 10.46.10.x/24 while R2 learned about network 192.168.0.x/24

So if you want, backup your current configs, clear both routers and apply the following:

Router R1:

hostname R1
!
!
!
!
interface GigabitEthernet0/0
ip address 10.45.10.2 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.0.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
password 0n10n
login
!
!
!
end

Router R2:


hostname R2
!
!
!
!
!
interface GigabitEthernet0/0
ip address 10.46.10.2 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.45.10.3 255.255.255.0
no shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
password 0n10n
login
!
!
!
end

 
Solution

soundtech85

Honorable
Sep 4, 2012
10
0
10,510


That is awesome, very cool. I will give this a shot first thing tomorrow when I go into the office and will report. Thank you so much for the help!