Sign in with
Sign up | Sign in
Your question
Solved

Blank flicker screen on monitor.

Last response: in Graphics & Displays
Share
September 9, 2013 3:58:27 PM

Whenever I turn on my PC, it shows a blank blue screen, which then flashes black for a second, and then blue again. This is the first time this has happened, and it was working fine yesterday. The last thing I did was install the Razer Surround program, if it matters. Everything but video output seems to be working, which makes me think it is a graphics card issue.

I've tried it on 2 monitors and it does essentially the same thing. Shows the black/blue "no input" screen, and then acts like it has found an input for a second, and then goes back to the blank thing.

I've tried pressing F8 repeatedly to get into safe mode and it did the same thing.

Oddly, I just unplugged everything, openned the case up, and replugged the PCI-e power cables into my graphics card. When I turned it on after doing this, everything went normal and I was able to get to the desktop, and then all of the sudden it went back to the blank screen.

Best solution

September 9, 2013 4:13:33 PM
Share

Sounds like your Graphics Card is on the way out. Does your board have an onboard GPU to try? Ivybridge / Sandybridge setups come with their own graphics onboard. If it works then your discrete card will be the problem most likely.
September 9, 2013 4:29:57 PM

Wamphryi said:
Sounds like your Graphics Card is on the way out. Does your board have an onboard GPU to try? Ivybridge / Sandybridge setups come with their own graphics onboard. If it works then your discrete card will be the problem most likely.


Turns out my HDMI cable and DVI cable had broken a bit somehow. I think my cat might have been chewing them or something. Anyway, I tried my HDMI from my PS3 and it worked, so I guess that was the problem. Now my mouse isn't working though, lol. I'll have to look into that...
!