What works if I can make it into BIOS - (ASUS P8H61-MX USB3 - Black Screen)

Symptoms:
  • The PC passes POST and then just gives a black-screen (if I disable the vendor splash screen, if I enable it the splash screen will remain) and then freezes (won't even accept CTRL+ALT+DEL).(My Display doesn't go into standby tho, so it seems the PC basically outputs a black image).
  • If I enter BIOS (which I am perfectly able to) and try to start the "EZ Flash Utility" to update the BIOS, the same thing, black-screen and it freezes.
  • If I enter BIOS and manually select a device to boot (which are correctly identified), the same thing, black-screen and it freezes.


Good-Symptoms:
  • I connected a SPEAKER and on boot it gives off one short *beep*, which seems to indicate everything should be fine, if I remove my RAM and reboot, it gives off 3 longer *beep*s, as expected, indicating this process works fine.
  • All components are correctly detected in the BIOS, CPU/RAM have the right vendor name and speeds.
  • Post screen looks fine


The Specs (I have ruled out the rest):
MOBO: ASUS P8H61-MX USB3 (90-MIBJF0-G0EAY0DZ)
http://www.asus.com/Motherboards/P8H61MX_USB3/

CPU: Intel Pentium G2120, 2x 3.10GHz, boxed (BX80637G2120)
http://ark.intel.com/de/products/65527/
(according to the QVM list, is officially supported, since BIOS v0401 )

RAM: G.Skill DIMM Kit 4GB, DDR3-1600, CL9-9-9-24 (F3-12800CL9D-4GBNQ)
(I'm unsure if the RAM is officially supported, tho it seems to be standard RAM)

What I have tried/Ruled out:
First of all, I have stripped the PC down to it's bare components, PSU/MOBO/CPU/RAM to test what I can eliminate and disconnected anything I wouldn't need (front USB connector from the casing etc.)

I reseated everything, , PSU connections, RAM, CPU

I tried running the PC both off one RAM stick (tried both slots with one RAM) and off both simultaneously [UPDATE1]

I have tried two different 400W PSUs, one of which works perfectly fine in another PC. - I made sure I used the right 4P CPU connector.
Instead of the built-in GPU, I installed a dedicated GPU and manually set it as default display output device in the BIOS, also gives a black screen.
I switched the RAM with the RAM of another PC, which is also DDR3, has bit different timings but is pretty standard RAM I expected to work. Unchanged behaviour.

I reset the CMOS multiple times, first through the jumper, then I took the CMOS battery out and put it back again. Unchanged behaviour.

I disabled every non-essential on-board component of the mainboard in the BIOS and plugged in a PS/2 keyboard instead of a USB keyboard, tried to start the "EZ Flash Utility", unchanged behaviour.

The question:
I am at a point where I think I have enough indications to return some of my components. I'm trying to narrow down potential problems. The fact that I pass POST and the fact that I can enter the BIOS and change settings around perfectly fine seems to indicate something works fine.

Does this sound like a damaged CPU?
Does this sound like incompatible RAM?
Does this sound like a faulty MOBO, maybe a badly flashed BIOS (my guess)

A question that's implicitly in here:
If I can make it into the BIOS, the POST passes and my components are deteced correctly, what conclusion can I draw?

Big BIG thanks for any kind of answer,
RobbinDH
3 answers Last reply
More about works make bios asus p8h61 usb3 black screen
  1. cpus barely ever fail. most likely your mobo or ram. it likely wouldnt even turn on if it was your cpu. try running it with only 1 ram module.
  2. ryan27968 said:
    cpus barely ever fail. most likely your mobo or ram. it likely wouldnt even turn on if it was your cpu. try running it with only 1 ram module.


    Thanks for your response.

    I forgot to mention it but I already run it off one RAM stick and I tried both of my purchased GSKILL and then another Kingston one from my other PC.

    I also tried both RAM slots.
  3. then it is likely a dead mobo.
Ask a new question

Read More

BIOS faulty BIOS Freeze Stuck Black Screen Motherboards unable to update Asus Past POST Splash Screen