Solved

Need help geting 5.1 surround sound through HDMI out from my Nvidia 560 Ti

I have a Zotac GeForce 560 Ti 2GB. I use Win 7 64bit and have the latest 320.49 GeForce drivers. I have connected my PC to my TV using the following config.

GeForce 560 Ti HDMI out -> Bose Lifestyle V30 -> Samsung TV

I can't seem to get 5.1 surround sound audio through the HDMI out on the graphics card. My Bose Home Theatre recognizes it as PCM 2.0.

It does however recognize my XBox 360 as Dolby Digital 5.1 and gives me surround sound for it but not for my PC.

Any advice?
7 answers Last reply Best Answer
More about geting surround sound hdmi nvidia 560
  1. go down to sound icon in system tray, right click it and select playback devices, highlight the hdmi output and select configure, change it to surround and 192khz 24 or 32bit depending whar your receiver supports.
  2. mauller07 said:
    go down to sound icon in system tray, right click it and select playback devices, highlight the hdmi output and select configure, change it to surround and 192khz 24 or 32bit depending whar your receiver supports.


    Thanks for replying but that hasn't helped. Here are screenshots of the problem I face.



  3. you may need to reinstal the nvidia hdmi driver.
  4. mauller07 said:
    you may need to reinstal the nvidia hdmi driver.


    I've even re-installed the Nvidia drivers by performing a clean install. Still no luck.
  5. Hi I am having the same issue with my GTX 470 with a similar setup HDMI from back of the card to a receiver to my tv. Did you ever find a solution to this? Please let me know this has been driving me nuts.

    Anonymous said:
    mauller07 said:
    you may need to reinstal the nvidia hdmi driver.


    I've even re-installed the Nvidia drivers by performing a clean install. Still no luck.
  6. Best answer
    SAme issue here. Just got my new Z-906 and audio from my pc through hdmi to the tv, then configured the speakers through SPDIF from my tv to the speakers.. still showing stereo :/
  7. It's an old thread, but I thought I would still post a resolution for this.

    The issue here is that the NVidia 560Ti is limited on what it will pass through the HDMI. You are better off picking up an TosLink cable and outputting sound through that separately then combining the 5.1 audio using a HDMI Audio Inserter (available through Jaycar in Australia) I used this http://www.jaycar.com.au/Sight-%26-Sound---Home/AV-Switchers-%26-Converters/Converters/HDMI-Stereo-Audio-Inserter/p/AC1636 which allowed me to add the 5.1 surround signal from the PC via Optical (Toslink) to the single outgoing HDMI successfully. Don't be fooled by the "Stereo" in the name, via optical cable, it is 5.1 and according to the specifications 7.1 is also supported(?) but I can't confirm that.

    These might also be of some use if you are trying to track them down (the last link is for the 4K/2K version)
    http://en.cypress.com.tw/store/catalog/app/product/CLUX-11CA/HDMI-Audio-Inserter
    http://en.cypress.com.tw/store/catalog/app/product/CPRO-11SI/HDMI-4K2K-Audio-Inserter

    The device itself is apparently marketed under different brands, but I think the Taiwan company Cypress Technology (as per above links) is the original manufacturer.
Ask a new question

Read More

sound 5.1 HDMI TV surround Geforce Graphics Bose