Solved

ASUS Sabertooth X58 Infinite Reboot after POST

I have a 2 1/2 year old ASUS Sabertooth X58. It does get through POST.
i hear a single beep when the Boot Up LED turns ON which typically indicates succesful POST.
There is display on the screen and I can enter the BIOS menu. But cant get beyond that.
PC keeps restarting. Replaced PSU with new one and also made sure HDD is fine on another PC. Tried all combinations of the 2 RAM sticks. Reset BIOS. Still no change. Beginning to feel something is wrong with MOBO or CPU, but no component failure signal during POST.
Kindly help me out.
5 answers Last reply Best Answer
More about asus sabertooth x58 infinite reboot post
  1. If leaving only DVD drive connected (with a bootable DVD inserted - Windows for example), does the board boot from it?
  2. tried it with a bootable USB stick and it didnt work either.
  3. Were the SATA devices removed?
    Can you borrow a RAM stick and test?
    Have you tried clearing the CMOS?
  4. hello. i tried all of the above. nothing made it work
  5. Best answer
    Try reseating the CPU and reapplying thermal paste.
Ask a new question

Read More

Asus Sabertooth LED Monitor Motherboards