Sign in with
Sign up | Sign in
Your question

Black ops 2 freezes at main menu despite my many attempts to fix it.

Last response: in Video Games
Share
September 15, 2013 4:49:57 PM

So I've been having this issue where COD will just freeze up at the main menu, and I have to end the process through task manager to get out of it.

It ran fine the day before, but not today.

No matter what I've done so far, nothing has seemed to fix it.

I've googled the issue and none of the solutions have been successful.

I've also used the thread "Master List of BO2 Fixes".

I've tried the obvoius ones: I restarted my computer, I fully reinstalled BO2, I fully reinstalled steam AND bo2 for a second time, and yet, nothing different.

Then I started to get annoyed. I verified the cache multiple times, I updated DirectX AND Windows, I updated, uninstalled, and reinstalled all my drivers, updated Catalyst, and even updated my BIOS. I've also tried various other solutions, but none seem to work.

I've litterally spent 5 hours trying to solve this issue, and it seems NOTHING I do seems to fix it.

This is seriously pissing me off, I spent $45 on this game, I would at least like to continue to play it.

My specs are as follows:

Windows 8 x64

Processor: AMD A6 4400-M APU @ 2.7 GHz with a "turbo speed" of 3.2 GHz

Graphics: Radeon HD 7520G

RAM: 8GB

Everything on my PC is up to date, including windows, device drivers, BIOS, and all other software.

Please help.
September 15, 2013 5:46:31 PM

JustSomeUserName said:
So I've been having this issue where COD will just freeze up at the main menu, and I have to end the process through task manager to get out of it.

It ran fine the day before, but not today.

No matter what I've done so far, nothing has seemed to fix it.

I've googled the issue and none of the solutions have been successful.

I've also used the thread "Master List of BO2 Fixes".

I've tried the obvoius ones: I restarted my computer, I fully reinstalled BO2, I fully reinstalled steam AND bo2 for a second time, and yet, nothing different.

Then I started to get annoyed. I verified the cache multiple times, I updated DirectX AND Windows, I updated, uninstalled, and reinstalled all my drivers, updated Catalyst, and even updated my BIOS. I've also tried various other solutions, but none seem to work.

I've litterally spent 5 hours trying to solve this issue, and it seems NOTHING I do seems to fix it.

This is seriously pissing me off, I spent $45 on this game, I would at least like to continue to play it.

My specs are as follows:

Windows 8 x64

Processor: AMD A6 4400-M APU @ 2.7 GHz with a "turbo speed" of 3.2 GHz

Graphics: Radeon HD 7520G

RAM: 8GB

Everything on my PC is up to date, including windows, device drivers, BIOS, and all other software.

Please help.

Your GPU is not suited to playing games, a gaming laptop or custom built PC would be much better suited for the task.
m
0
l
!