Sign in with
Sign up | Sign in
Your question

Toshiba Satellite C855D-S5315 Network Adapter driver install

Last response: in Windows 7
Share
September 16, 2013 8:33:13 AM

Migrated from Windows 8 to Windows 7 Ultimate on my daughter's college laptop. Information as follows:
Windows 7 Ultimate
Processor: AMD E-300
RAM 4.00 GB
32 Bit OS

I completely wiped the hard drive to install Win 7, and all of the drivers from the Toshiba are gone. I am trying to get online to download the appropriate drivers, and am receiving the following message:

Windows did not detect a properly installed network adapter. If you have a network adapter, you will need to re-install the driver.

I have gone to the toshiba site an downloaded/installed the following drivers:
RealTek LAN Driver
Posted Date: 2012-08-23 | Version: 8.2.612.2012 | Size: 7.8M
Atheros LAN Driver
Posted Date: 2012-08-23 | Version: 2.1.0.6 | Size: 7.72M

Help? I know there were other posts on this, but in trying the suggestions they did not help. Still cannot get the laptop to recognize any drivers.
a b $ Windows 7
a b \ Driver
September 16, 2013 9:45:17 AM

What's the result of the driver install? Do you have a wired or wifi connection? Any exclamation marks in device management?
m
0
l
September 16, 2013 9:48:08 AM

noidea_77 said:
What's the result of the driver install? Do you have a wired or wifi connection? Any exclamation marks in device management?


Yes, in device management, the device functions read as follows:
!Ethernet Controller
!Newtork Controller
!USB2.0-CRW

The device drivers are not installed.
m
0
l
Related resources
a b $ Windows 7
a b \ Driver
September 16, 2013 9:54:49 AM

Try the generic win7 drivers from RealTek and Atheros. USB2.0-CRW seams to be the card reader. No idea, where you get a win7 driver for that.
m
0
l
September 16, 2013 11:34:06 AM

noidea_77 said:
Try the generic win7 drivers from RealTek and Atheros. USB2.0-CRW seams to be the card reader. No idea, where you get a win7 driver for that.



Still no luck. I was able to download and install the REaltek PCIe FE Family controller, but there is still not an option to connect.

m
0
l
a b $ Windows 7
a b \ Driver
September 17, 2013 8:50:05 AM

Are the exclamation marks gone or still there? How do you want to connect? LAN or Wifi?
m
0
l
September 17, 2013 11:13:08 AM

noidea_77 said:
Are the exclamation marks gone or still there? How do you want to connect? LAN or Wifi?


All exclamation marks are still there. Connecting via WiFi would be great, as all other laptops in the house are configured.
m
0
l
!