Sign in with
Sign up | Sign in
Your question

Corsair H80i startup clicking noise

Last response: in Components
Share
September 16, 2013 2:48:36 PM

Hello guys, so 2013 is my year of mini ITX gaming pc. I made a new config with the following spec:

MB: New coming Asus Maximus VI Impact
CPU: Intel i5 4670K
GPU: MSI TF GTX 760 OC
RAM: Corsair Vengeance Pro 8G 1600
CPU cooler: Corsair H80i
PSU: Seasonic X serie 650
SSD: Samsung Pro 840 128G
HDD: Seagate Barracuda ST1000DM003 1T
Case: Bitfenix Prodigy white

So the installation was not easy, but I finally managed to install all carefully. I made a super clean windows 7 ultimate 64 bit installation and installed all driver correctly.

The only problem is this: I get this annoying hard drive clicking noise from the H80i. I don't know if it is the pump or the fans or the radiator. But I am pretty sure that i comes from the cpu cooler.

Here you go http://www.youtube.com/watch?v=CVm4jGNhxSQ

So what do you think about this issue and which component could be the source of the problem? Thank you very much in advance. Regards.


September 16, 2013 3:00:23 PM

Try disconnecting the fans one at a time(to see if the noise goes away. 1 fan is more than enough to keep the coolers temps in check). It does not sound like a pump issue.
m
0
l
September 16, 2013 8:38:01 PM

manfod said:
Is there something hitting a fan after you reassembled?

That was my first thought as well. I had a fan hitting a cooler on startup before it settled into its final height(but mine was very crammed into place)..
m
0
l
!