Re-installed windows 7, Ethernet controller wont work

I formatted and did a complete clean install of windows 7 ultimate 64 bits. I'm unable to connect to the internet via Ethernet cable. I checked device manager and find that I'm missing the Ethernet controller drivers. I tried fixing it in device manager but I have no luck. I went to the motherboard manufacturer's website to download the drivers. I have a Asrock G41M-VS3 motherboard, which has a Atheros PCIEx1 LAN AR8132L. I downloaded the atharos drivers that were listed in for my motherboard on the official website, but now I get the following error when I try to install them '' installer can't find atheros AR81 family Ethernet controller on your system'' How do I know if my computer is recognizing the LAN adaptor? I'm getting so frustrated here
Reply to Anonymous
32 answers Last reply
More about installed windows ethernet controller wont work
  1. Check if enabled in BIOS.
    Reply to rolli59
  2. Have you installed the mobo drivers from the mobo's website - that's where the drivers for your ethernet controller are ;)
    Reply to Tradesman1
  3. rolli59 said:
    Check if enabled in BIOS.

    I went on the bios many times, changed bios settings to default, etc. I really don't know what I'm doing here. What am I suppose to do here?
    Reply to Anonymous
  4. Tradesman1 said:
    Have you installed the mobo drivers from the mobo's website - that's where the drivers for your ethernet controller are ;)
    As I already said my motherboard is a Asrock G41M-VS3, I go to their website and download the drivers for my version. When I try to install them I get this error '' installer can't find atheros AR81 family Ethernet controller on your system''
    Reply to Anonymous
  5. In defaults LAN controller is disabled, look through BIOS menu find it and enable.
    In BIOS advanced tab, Chipset configuration at the bottom.
    Reply to rolli59
  6. In defaults LAN controller is disabled, look through BIOS menu find it and enable.


    I don't see any option like that.
    Reply to Anonymous
  7. rolli59 said:
    In defaults LAN controller is disabled, look through BIOS menu find it and enable.
    In BIOS advanced tab, Chipset configuration at the bottom.

    I can't find any option like that.
    Reply to Anonymous
  8. This your board ftp://66.226.78.21/manual/G41M-VS3.pdf That is the manual!
    Reply to rolli59
  9. NOt positive about the BIOS, but there's a rev 1 and a rev 2 of the mobo, might check that
    Reply to Tradesman1
  10. rolli59 said:
    This your board ftp://66.226.78.21/manual/G41M-VS3.pdf That is the manual!

    Onboard lan is enable
    Reply to Anonymous
  11. Same in both manuals, just checked. Then check if you can find the driver for it on your motherboard disk.
    Reply to rolli59
  12. Tradesman1 said:
    NOt positive about the BIOS, but there's a rev 1 and a rev 2 of the mobo, might check that


    This is the second time i formated my computer this week. The first time I manage Installed those drivers from the site and it worked fine. I kept my old files tho, and l later updated the bios after that, Now I completely formated the hardrive and did it again due to problems. Wont let me install
    Reply to Anonymous
  13. rolli59 said:
    Same in both manuals, just checked. Then check if you can find the driver for it on your motherboard disk.
    Don't have the disk. This is my second re installation this week. First time I manage to get the drivers working from the site. Now I can't :(
    Reply to Anonymous
  14. ver 1 of the board has driver 1.0.0.32 ver 2 has driver 1.0.0.45, have you tried both?
    Reply to rolli59
  15. rolli59 said:
    ver 1 of the board has driver 1.0.0.32 ver 2 has driver 1.0.0.45, have you tried both?


    I only tried the one listed for my board and my windows version. Atheros Lan driver ver:1.0.0.32. How can I try the other one?
    Reply to Anonymous
  16. Reply to rolli59
  17. rolli59 said:

    It just gives me the same message when I try to install it
    '' installer can't find atheros AR81 family Ethernet controller on your system'''
    I don't understand why it wont work, I did this a week ago and everything went fine. When I go to network connections the page is all blank. Is there anyway to check if my computer is recognizing the LAN, like through task manager or something?
    Reply to Anonymous
  18. My guess is that the problems you are experiencing and prompting the windows installs might have to do with failing motherboard and the LAN might be simply dead.
    Reply to rolli59
  19. rolli59 said:
    My guess is that the problems you are experiencing and prompting the windows installs might have to do with failing motherboard and the LAN might be simply dead.

    My computer is running just fine except for the LAN issue. And it was working 5 hours ago till I decided to format and re-install windows 7.
    Reply to Anonymous
  20. So what is prompting you to install windows over and over again?
    Reply to rolli59
  21. rolli59 said:
    So what is prompting you to install windows over and over again?

    I decided to change from 32 bits to 64. First time was having trouble with the updates. Second time everything is running smoothly after a clean install. But now the LAN isn't working
    Reply to Anonymous
  22. Do you have the 64bit driver(s) or still trying to load 32bit
    Reply to Tradesman1
  23. Tradesman1 said:
    Do you have the 64bit driver(s) or still trying to load 32bit
    64, something weird just happened. It suddenly worked.
    Reply to Anonymous
  24. Strange in deed. Windows run any updates in the meantime?
    Reply to rolli59
  25. I've been practicing my mind over matter and think I did connect with your PC ;) just kidding, glad all is well !
    Reply to Tradesman1
  26. rolli59 said:
    Strange in deed. Windows run any updates in the meantime?


    The vs2 one started working, weird

    Yeah updates are working fine, it seems the problem is somehow related with the drivers skipping the install. I'm having troubles installing the audio drivers now. Noticing that the install goes way to fast. You think it has something to do with my hardware not being compatible with 64 bits?
    Reply to Anonymous
  27. It should be compatible.
    Reply to rolli59
  28. rolli59 said:
    It should be compatible.

    Should I go back to 32 bits?
    CPU: Intel(R) Pentium(R) dual CPU E2200 @ 2.20Ghz

    Memory(Ram) 4.00gbs

    Graphics: NVIDIA Geforce 8400 GS

    Motherboard:Asrock G41M-VS3
    Reply to Anonymous
  29. I would stay on 64bit it is all compatible.
    Reply to rolli59
  30. Anonymous said:
    I formatted and did a complete clean install of windows 7 ultimate 64 bits. I'm unable to connect to the internet via Ethernet cable. I checked device manager and find that I'm missing the Ethernet controller drivers. I tried fixing it in device manager but I have no luck. I went to the motherboard manufacturer's website to download the drivers. I have a Asrock G41M-VS3 motherboard, which has a Atheros PCIEx1 LAN AR8132L. I downloaded the atharos drivers that were listed in for my motherboard on the official website, but now I get the following error when I try to install them '' installer can't find atheros AR81 family Ethernet controller on your system'' How do I know if my computer is recognizing the LAN adaptor? I'm getting so frustrated here


    hey man which link of driver actually worked :)
    Reply to andtherex
  31. Not sure but it's probably been updated, this thread is from about 10 months ago ;)
    Reply to Tradesman1
  32. andtherex said:
    Anonymous said:
    I formatted and did a complete clean install of windows 7 ultimate 64 bits. I'm unable to connect to the internet via Ethernet cable. I checked device manager and find that I'm missing the Ethernet controller drivers. I tried fixing it in device manager but I have no luck. I went to the motherboard manufacturer's website to download the drivers. I have a Asrock G41M-VS3 motherboard, which has a Atheros PCIEx1 LAN AR8132L. I downloaded the atharos drivers that were listed in for my motherboard on the official website, but now I get the following error when I try to install them '' installer can't find atheros AR81 family Ethernet controller on your system'' How do I know if my computer is recognizing the LAN adaptor? I'm getting so frustrated here


    hey man which link of driver actually worked :)


    rolli59 link worked for me. http://www.asrock.com/mb/Intel/G41M-VS3%20R2.0/?cat=Download&os=Win764
    Reply to Ronny Jimmy
Ask a new question Answer

Read More

Windows 7 Drivers Ethernet Controller