Solved

New computer - No display from 7970

The problem I have is I don't have the option to switch out another graphics card to test the system, or update bios, or anything really. The motherboard has no on-board graphics so it's literally impossible for me to even remedy the problem if it's software related. Tried all of my slots. Everything on my system starts up, including the fan running on the card. I've tried reseating the card in various slots, reinserting the pings/prongs, different displays, and turning off fans to see if it was a power drain. My motherboard doesn't beep, and displays a 00 upon startup. This is a brand new PC, so it's launching nothing but the BIOS assuming that it's actually running. Which I have no way to tell.

Specs: RAIDMAX HYBRID 2 RX-730SS 730W ATX12V V2.2/ EPS12V SLI Ready CrossFire Ready Modular Power Supply

AMD FX-8350 Vishera 4.0GHz (4.2GHz Turbo) Socket AM3+

ASRock 970 EXTREME4 AM3+ AMD 970 SATA 6Gb/s USB 3.0 ATX AMD Motherboard with UEFI BIOS

SAPPHIRE 21197-00-40G Radeon HD 7970 3GB 384-bit GDDR5 PCI Express 3.0 x16 HDCP Ready

G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900)

COOLER MASTER Hyper N 520 RR-920-N520-GP 92mm Sleeve CPU Cooler

Western Digital WD AV-GP WD10EURX 1TB IntelliPower 64MB Cache SATA 6.0Gb/s 3.5"

SAMSUNG Black SATA DVD-ROM
3 answers Last reply Best Answer
More about computer display 7970
  1. Best answer
  2. It was a fairly immediate fix. I had the cpu connectors (I have an 8 prong power connector) on the furthest 4 as opposed to the nearest 4. It's working now. I feel like an idiot. Thanks a lot. I appreciate it.
  3. Great enjoy!
Ask a new question

Read More

Graphics