wont boot past bios

built a computer 2+ years ago and it worked great until a few weeks ago mobo was the culprit had a asrock 990fx professional replaced it with a asrock 970 extreme 4 plugged everything in and turn it on and it brings up the asrock page with bios options but cannot use keyboard to select anything or get past that page unless i unplug all sata devices then it will bring up page with cpu and ram specs any advice on what to do now or what to try have removed all hardware and reinstalled a few times now cleared cmos etc
6 answers Last reply
More about wont boot past bios
  1. Do you have your keyboard plugged into a usb2 or usb3?
  2. tried all usb 2 usb 3 and bought a ps2
  3. with the hard drive unplugged did you update the new mb bios to the newest rev to make sure it not a bios bug. make sure the sata ports set to achi mode and try one drive at a time to see if one drive has gone bad or the sata cable and causing the pc to hang.
  4. cant get past the asrock bios starting screen wont let me into bios to change anything have mobo out of case on cardboard box attempting different configurations but no luck with anything
  5. try clearing the cmos. if not some mb have an f key that you can hit to go into the bios flasher screen.
  6. cleared cmos a few times now had the battery out for 10 mins or so when i had to find another keyboard after i broke one over my knee
Ask a new question

Read More

BIOS ASrock Motherboards