SApphire HD 7970 Boost OC Display issue

Hello Experts,
I just bought Sapphire HD 7970 and plug that in.Games are playing flawless. Furmark bench mark as follows:

Furmark version 1.6.5
[SCORE :15901 o3Marks]
FPS MIN 230
FPS MAX 345
FPS aVG 265
Time 60000ms
Res: 1280x 1024
Renderer: AMD radeon hd 7900 series
active gpu:1
Drivers catalyst: 13.9 -13.152-130830a-162200C-ATI(8-30-2013)
CPU-AMD FX 8350 Eight Core
Cpu speed: 4018 MHZ
OS:WINDOWS SERVER 2007 VER 6.2 BUILD 9200 [NO SERVICE PACK]


I am using Windows 8 64bit.I don't know why it is showing windows server.The main problem is youtube not displaying over 360p. when i press for 720p , it shows small hd icon but videos are like 360p.Please help
4 answers Last reply
More about sapphire 7970 boost display issue
  1. what browser are you using?
    try a different one? chrome or firefox as opposed to ie. Are you using it in desktop mode windows 8?
  2. I tried on both Chrome and Firefox.Same result
  3. hazan said:
    I tried on both Chrome and Firefox.Same result


    Hi - Have you tried videos other than youtube? Just wondering if it's the source
    and not your hardware.
  4. toyftw said:
    hazan said:
    I tried on both Chrome and Firefox.Same result


    Hi - Have you tried videos other than youtube? Just wondering if it's the source
    and not your hardware.


    Even HD movies are not that clean and crisp.Do I need to re install my Windows 8?
Ask a new question

Read More

Games Sapphire Graphics Boost HD Displays