Solved

ASRock P67 Extreme4 won't boot longer than 5 second with more than 2 sticks of Ram

I have an ASRock P67 Extreme4 motherboard and 4 sticks of G.Skill Sniper 4x4GB Ram and the computer won't boot for longer than 5 seconds if a stick is plugged into the third or fourth slot, no matter what the combination of ram. There could be nothing in the first or second or one in either of them or both, if a stick is plugged into the third or fourth or both slots the the computer boots for 5 seconds, then shuts off, then boots again for 5 seconds and so on.

Funny thing is the computer worked fine for a year and a half. I just came home one day, turned on the computer, and it started this cycle.

Any help is appreciated.
10 answers Last reply Best Answer
More about asrock p67 extreme4 boot longer sticks ram
  1. Try resetting the CMOS, might also check for BIOS updates, but start with sticks in slots 1-3 only, boot into BIOS , if that goes OK raise the VCCIO voltage up to 1.15, save, exit, shut down add other two sticks and try again
  2. Did that and already had the BIOS updated to the newest version. Tried a stick in slots 1 and 3 and again it fell into the loop.
  3. Sounds like a bad channel, or possibly bent pins in the CPU Socket
  4. I just received the motherboard back from ASRock yesterday. they apparently tested it under Windows, updated the BIOS, and tested the LAN, sound, and video
  5. Check and make sure the Sticks are securely installed and haven't loosened during shipping, would also send off an email to the Rock and let them know there is a problem with the mobo they just sent to you - explain all fully - otherwise they may want to blame you for any problem -
  6. What I meant was I just received it back from ASRock. I've had this moabo for over a year. It recently started doing this, I sent it as an RMA to ASRock and they supposedly tested it and sent it back. Now if its the same one or a replacement I don't know yet but it is still doing the exact same thing it was doing before I sent it to them.
  7. Sounds like a bad channel or possibly a bad CPU (the memory controller)
  8. Do you mean the actual CPU or the pins on the motherboard? I checked the pins today and they all look straight and perfect.
  9. After reading up on Newegg (where I bought it), it seems a lot of people are having the board die on them after a year of use. Thinking I might find another moboard
  10. Best answer
    There's another Rock, the Z77 Extreme 4 which is a geat mobo, you might look at, have had mine since they were released and no problems at all, it's also the best selling and best rated Z77 (per the Egg)
Ask a new question

Read More

RAM Boot ASrock Motherboards Computers