Sign in with
Sign up | Sign in
Your question
Solved

Rome Total War DirectX 9 Issue

Last response: in Video Games
Share
September 30, 2013 7:50:29 PM

Hi, after perusing a bunch of videos, I decided to buy Rome Total War Gold Edition. I bought the download off of Amazon so I didn't have to deal with shipping. I believe I have played this game on my current computer many years ago. Anyway, on to the issue. It seems pretty common, but when I start it up, it says something to the effect of DirectX 9 needed (apologies, I don't remember it verbatim). My computer says I already have directX 9c. Things to note: I only just downloaded the game, it hasn't been sitting on my computer, and also, there is no directX file in the program files for Rome Total War. I downloaded directX 9c from microsoft after I tried to play the game and it didn't work (though I might have already had it), and I've tried copy pasting my DirectX file from WINDOWS into the Rome Total War file. Anyway, I'd appreciate some help, so I can get to the rts goodness. Please respond in detail, thanks.
October 1, 2013 12:01:40 AM

Rome Total War is not an RTS it's a turn based GSSG ("Grand Scale").

:)  on to the question:

My suggestion is delete the entire game via control panel, then making sure all folders of the game are removed, including in my Documents (since you haven't played these should be empty)

Now do a clean install of the game, if it asks to install Direct X9C (if you are still using that I am guessing your still on Win XP) just confirm that you wish to install it. (Sometimes these bugs do happen even if you have the latest version on) Now just download the game from Steam (My 2 RTW games aren't Steam) but yours should be.

For historic purposes play the prologue & then start with Alexander (I did that once, it was quite fun) (Prologue just to get the hang of things)

Let me know what happens after you did this (As a rule of thumb do not copy installed files into game folders if you do not know where to place them/if the game has not worked before)

If it is still not fixed or you have already done this let me know also so we can find a sollution
m
0
l
October 1, 2013 4:24:25 PM

Ok, so I uninstalled the game. I also installed Steam. How am I supposed to reinstall it from Steam? It just wants me to buy it all over again. I originally bought the download from Amazon.
m
0
l
Related resources
October 2, 2013 12:50:23 AM

Lagiacrus said:
Ok, so I uninstalled the game. I also installed Steam. How am I supposed to reinstall it from Steam? It just wants me to buy it all over again. I originally bought the download from Amazon.


Simple you click on Steam open it up

You will see some menu tabs like Store, Library ect. go to games.

Here you will click on add non steam game to library

Just use the location of where you reinstalled RTW. (The new clean install I suggested)
and add selected program.

I have 2 Rome Total Wars (originals, because I bought the game and Barbarian invasion and later i bought the C.E. so I can have Alexander as well if I still had my copies I would have mailed you 1 of the 2 so you can try my disks :p )

Unfortunately it's 6 generations back so I don't think anyone on the actual Total War forums will be able to help since we are all playing RTW2, very few people are still playing Shogun 2. So the best would be to use Steam forums, but again since it's so old only a few elitists still play (mainly because RTW2 was laggy but that's been fixed) I really wish I could help more but if I remember correctly the DX9 issue was a fluke that happened to many people. Not most, but many. So as I suggested, wipe clean off the system, clean install, check drivers, use steam. Hopefully it works.
m
0
l
October 2, 2013 6:48:56 PM

Aaaugh I wana break something. So yesterday, after uninstalling, I clicked a launcher thingy in the packet of files that Amazon downloaded before installing. Severely faster than the amazon install, the two games installed. I was on my admin prof. I tried RTW, and the game worked, and I played a while. Today, I tried on my own profile. The game, first BI, worked fine, though I never actually tried any games (there weren't any). So I booted up RTW, and 3 times when I tried doing online matches, the game crashed. So I went back to the admin prof, and the game gives me the directx 9 error and my screen spazzes out, saying something about input. I went back to my own prof, and it now has the same issue.....
m
0
l

Best solution

October 2, 2013 11:43:09 PM

I suggest contacting Amazon support man I can't help any further :)  that is purely amazon.

Just a small thing I want to add, try forcing the game to install, play, work in administrator (in your profile). If you have admin privileges, which you should since it's your pc.
Share
October 4, 2013 5:09:48 PM

So, apparently, if it's the first thing I do and I don't close out and log in first on my admin profile, I can get it to work. Wierd. Thanks anyway.
m
0
l
!