Sign in with
Sign up | Sign in
Your question
Solved

Using faster than 1866 Memory with the AMD A10 6700

Last response: in Overclocking
Share
October 1, 2013 2:08:08 AM

Hi,

It's not often that i post here, but here goes.

I have memory rated at 2400MHz and an AMD A10 6700.

Does anyone know of a way or a guide to help me run my memory faster?

I've tried a few settings in the UEFI but it seems it won'T crank up past 1866.

Any suggestion welcome.

Mobo is ASROCK FM2-A85X-itx



Don't...

Bump posts


http://www.tomshardware.com/forum/283384-33-read-first
a c 79 K Overclocking
October 1, 2013 10:48:38 AM

Did you load the XMP setting?
a b K Overclocking
October 1, 2013 12:02:08 PM

Check out this LINK
Related resources
Can't find your answer ? Ask !
October 2, 2013 12:46:21 AM

Yeah, tried the xmp settings.. and also manual. I can set it to 2133, but after a reboot it defaults to 1866 (single channel!)
Thanks for the link arthurh, but unfotunately the chart therein doesn't have my A10 6700 on it.

From reading it though, the memory controller is on the CPU itself as it has been since we went to K8 i believe.

The answer i was looking for was using memory timing dividers.. (memory ratio)

From a simple bit of calculation.. i reckon that if i get a ratio of 12:1 - mem/cpu

That would give me a DDR of 12x2 0 2400 while CPU baseclk = 100..

I just don't know how I'd do that though or even if i can!
a c 79 K Overclocking
October 2, 2013 8:18:16 AM

Can you please post the exact make and model of the RAM kit?
October 3, 2013 12:44:32 AM

Yep! It's "TeamGroup 8GB KIT PC3-19200 DDR3-2400 CL11 2x4GB xtreem Vulcan" - It's obviously rated for 2400 and CL11 - should work.

I don't think it's the ram fault, i'm sure it's capable ram. But it's a matter of tricking the memory controller on the APU to use higher settings.. even if this means messing with ram:cpu timings.
a c 79 K Overclocking
October 3, 2013 7:08:58 AM

Look here:



See where it says "XMP 1.2 Profile..."? When you set the XMP, what does it show for you?

You can also flash to the latest stable bios to see if it corrects the issue.
October 4, 2013 1:42:48 AM

Hi ihog.. I just don't think it can be done with this BIOS /UEFI and the settings.

When i set it to XMP it 'wants' to default to 1866, even though XMP 1.3 for this RAM = 2400 CL11 and it says as much when you try to select it. But when you do the speed defualts to 1866.
Setting it manually to 2133 or 2400 has the result that after the restart, it says 1866 SINGLE channel-
Setting the speed back to 1866 gives me double channel again.
The BIOS is 1.5 and latest is 1.6 but as far as i can tell the only difference according to ASROCK is the URL for BIOS updates has changed.. no technical fixes in 1.6 compared to 1.5..
I'm getting close to admitting defeat!!
Unless there is a Windows based utility i could try.. but i just dont think it can be done with my setup.
October 4, 2013 5:53:02 AM

I had issues with ram speed with my asrock fm2 board and 5800k when trying to go past 1866. Updating to the latest beta bios helped, even though it said nothing about ram in the comments. Im on holiday at the moment so I cant check my bios settings, but have you considered upping the NB and ram voltage? Maybe its simply not stable at those speeds with default voltage.

Best solution

a c 79 K Overclocking
October 4, 2013 8:01:45 AM
Share

Try updating the bios. You never know. The bios you have installed could be minimally corrupted.
!