Solved

Bought a NZXT M59 case but ran into problems

Hello everyone, I recently purchased an NZXT M59 case expecting it to work without any problems. I tried installing everything and here is the problem I am having:

I've been to other forums and they've told me to plug the front panel connectors into a so called "P17" port on my motherboard which I don't seem to have like shown in this picture.

If needed, the pictures and information for my motherboard are on this link.
I really want to get this to work, but I feel like I would need to buy a new non-OEM motherboard for it to work.

If anyone could help me out, I would really appreciate it!
3 answers Last reply Best Answer
More about bought nzxt m59 case ran problems
  1. http://www.tomshardware.com/forum/336782-31-where-reset-power-harddrive-connectors
    is there any j18 connection??? is the mb new or used. if you just got it call the vendor and tell them someone removed j17 port and return it.
  2. smorizio said:
    http://www.tomshardware.com/forum/336782-31-where-reset-power-harddrive-connectors
    is there any j18 connection??? is the mb new or used. if you just got it call the vendor and tell them someone removed j17 port and return it.


    It does indeed have a J18 port as seen in this picture circled in red that I just took inside my case. Keep in mind that I am using my OEM case and OEM motherboard, and I've had this computer for two years.
  3. Best answer
    have you tried following the oem case wires. the mb maker was foxcon and a lot of the photos online show pin on the j17 port. if there gone then there has to be another port that hp used for power on and reset.
Ask a new question

Read More

NZXT Cases Systems Motherboards