Solved

Problem intalling/updating ATI catalyst control center

Hello i check the fourm for this problem before but couldnt find a soultion to my problem.

I am trying to update my ATI catalyst control center from version 12.1 (yes that old!) to the latest 13.9 but it fail while installing. While installing it say packaging install error and doesnt install anything, i have tried removing all drivers and also removing adm files from registery with phyxion sweeper but it still fail each time.

I got .NET 4.0 (updated to be sure) and i tried everything else but i can't get pass that error not even installing version 12.4. im stuck in the past!

*ops forgot to mention specs, using redaon 4890, windows 7 64bit

If anyone know a solution it would be great.
4 answers Last reply Best Answer
More about problem intalling updating ati catalyst control center
  1. Best answer
    I'm sure you need to get the driver from here: http://support.amd.com/us/gpudownload/windows/legacy/Pages/legacy-radeonaiw-vista64.aspx

    You have a legacy card, and their latest is 13.1 only.
  2. Ah worked like a charm, thank you!
    The CCC tried to get me to update to that and i also tried updating in the past with many versions like 12.4 but i guess it never realy updated.

    Thank again for the fast answer :)
  3. No problem. :-)
  4. Melderv said:
    No problem. :-)


    I am having the same issue on a fresh install of 7 64 bit using catalyst 13.9 drivers. The control center freezes. When I go to AMD it gives me only the option for 13.9 not 13.1 I have a 4870x2
Ask a new question

Read More

ATI Catalyst Graphics