Sign in with
Sign up | Sign in
Your question
Solved

USB Flash Drive Not Recognized (Recovery)

Last response: in Storage
Share
October 6, 2013 12:12:51 PM

Much like previous related issues, my flash drive is not recognized by Windows 7. It plays the tune that it's plugged in, yes, and Device Manager knows it's there, but I cannot access it.

This issue started after I had it plugged in into the Xbox 360. I would browse files on the console (movies, music, pictures) and do nothing else. The Xbox 360 recognizes it, but my PC does not. I may already know the answer and cold truth, but is there any way to recover such files?

I have tried both Xplorer360 and TestDisk programs to attempt and recover my data.
a b G Storage
October 6, 2013 1:15:36 PM

Did you format it in the XBox as a Storage device? If so it formatted it in XBox's own format. You would need to go to Disk management and reformat it.

Right click Computer --> Manage --> Storage --> Disk Management

In there you should see your USB drive. On the long box right click delete partition. Then once delete right click Create New Partition and follow the instructions.

If it was formatted in a PC then it might just not be giving you a drive letter. Go to the same place but when you right click on it select "Change drive letter" and see if it has a drive letter or not. If it doesn't add it. If you can't add it then it means its not formatted in a format where windows can read it.
October 6, 2013 3:02:38 PM

drtweak said:
Did you format it in the XBox as a Storage device?


No, I did not. Like I mentioned above, I only plugged in the flash drive into the console to browse through and view my files (music, movies, etc). I did this for the reason of my PC being repaired elsewhere. Before then, I could access the drive with no problem on any computer.

The issue I'm having is that I can't access the drive itself. It won't even show on which drive letter it is. The computer recognizes there's a storage device plugged in (via Device Manager and Devices and Printer), but it's like it can't recognize what type. Even in its description, it says there's 0MB of data. That's obviously untrue, as the Xbox 360, clearly, still allows me to see the files.

I know I'm pretty much screwed as is. I've received multiple comments of "Oh, man. As soon as you put it in the console, the Xbox 360 'owned' it."

I just want to know if it can be reversed, where I can once again access it on my PC. If at the very least, able to salvage my data from the flash drive.
Related resources

Best solution

a b G Storage
October 6, 2013 10:30:14 PM
Share

I use a USB for media files every day on my xbox and unless your format it in xbox it doesnt "own" it. Try going to disk management like i said see if it says anything about it there. Unless you meant disk management and not device manager. Have you tried it in another PC? Sometimes partitions get corrupt and it may need a check disk ran on it but the xbox can still read it. Had this issue back in the days of floppies. Will work in some but not others.
October 8, 2013 12:05:45 PM

I attempted to access the drive through Disk Management, but it still would not recognize the drive. Not enough for me to be able to modify it. It just knew something was plugged in, a storage device, but knew nothing more of it. Very strange. I even tried accessing it through another machine (PC), and it would not recognize it, either.

Regardless, this issue has been solved. I thank you, drtweak, for your time and help with my problem.

How was it solved?

Well, I left the drive plugged into the machine when everything else failed and shutdown the computer. Didn't even bother ejecting it. I was just that frustrated and down. When I powered up my computer the next day, a pop-up window from Kaspersky appeared right after Windows loaded asking if I wanted to scan the drive for infection. I immediately knew my PC had finally been able to recognize it b/c it only does that when something is plugged in.

Sure enough, I could browse through all my files. You were right in it getting corrupted somehow. I made sure to back it up on my external hard drive now. Heh.

To all others that may be cursed with this similar problem, try restarting the computer with the drive plugged in. It worked for me, evidently.

And again, thank you.
a b G Storage
October 8, 2013 5:09:16 PM

Wow hahaha yea never had an issue like this before. Thats weird, and that would kinda make sense. Its like having a PC with a non Hot Swap SATA port. You plug in a SATA HDD and you get nothing. Once you restart the Bios sees that its there and adds it. It does the same thing for USB storage devices so that may have been what was up. I'll have to keep that in mind.
November 29, 2013 6:20:14 AM

by following drtweaks guide, i was able to try different situations and finally got the darn drive to be recognized in "my computer" as a drive with a letter for a drive. what seemed to work for me was to finally reformat (not quick format) to fat32, then go above to the upper section and the drive was there but i had to right click and designate a letter for the drive and wah lah, my flash drive finally showed up in "my computer", yea, thank god for my hard headedness or i would have given up long ago and pitched as bad flash drive. :) 
January 5, 2014 6:07:26 PM

thanks for the helpful info.
January 28, 2014 2:32:52 PM

Does it show up on computer as a drive letter like E:? If not, you may go to device manager and then assign a drive letter to the usb drive. here's a good guide you can follow
http://goo.gl/9d17Ia

After you can see it in computer as drive letter, you can try to access it. If still got problem, you may try to recover data from the device by follow this guide
http://goo.gl/fXb3vM

You may consider scan the usb device with anti-virus software to make sure that it is clean. Microsoft Secuirty Essential and AVG free are recommended
http://goo.gl/rx1KFq
http://goo.gl/og4AB
February 3, 2014 11:09:26 AM

First off, if you ever plan on recovering any data, you must make sure you don't format or do anything that writes data to the drive. Once data is written over it is gone. Second for data recovery on flash drives that aren't recognized, look at the second type of recovery here http://www.sertdatarecovery.com/flash-drive-recovery/ho... Also keep in mind it's always best to eject a USB drive when available, you can burn out the controller on the PCB and your going to need expensive data recovery at that point.
!