Sign in with
Sign up | Sign in
Your question
Solved

FPS capped to 30 after temperature drops

Last response: in Video Games
Share
October 6, 2013 3:01:53 PM

Hello, i have this annoying problem with my new pc. Whenever i play games like Far Cry 3 or Batman Arkham City, my fps goes with a good start but after like 30 secs - 1 minute the temperature suddenly drops from 74c to 68c and the fps goes down as well. I'm only having this problem in Far Cry 3(dx11) and Batman Arkham City(dx11), though.

my spec:
i7-3770k @ 4.5 ghz
GTX 760 Asus Directcu II
MSI z77 Thunderbolt
Gskills Ripjawsx(2x4)
October 6, 2013 11:37:40 PM

i also tried disabling vsync or used adaptive vsync and it worked. but i have a weird problem here, when i start the game i'm only getting 30 fps but when i alt+tab out then go back to the game, my fps goes up from 30 fps to 40+ fps. it's weird. i also uploaded a video of it on youtube. but in this case i used alt+enter. here's the video: http://www.youtube.com/watch?v=tD7pQLqpTg0
m
0
l
Related resources
October 7, 2013 12:40:57 PM

Its definitely vsync bringing it down to 30..

If not have you tried lowering to high or medium detail preset and seeing what happens? I tend to customize settings a little below ultra in action games until I can get 60 fps constant because when it drops to 30 I can't deal with it.

Seems like its something to do with adaptive vsync maybe having adaptive vsync forced on and normal in game Vsync at the same time does this, but of course I'm guessing now, maybe someone more familiar with Adaptive could help. Sorry :??: 
m
0
l
October 9, 2013 1:38:01 AM

Hi, having the same issue. Took my card back for testing and technitions says its 100%. But on my pc still same issue. Any ideas?
m
0
l
October 11, 2013 2:01:04 PM

MAybe your CPU is overheating . check your CPU temps . try downclocking it a bit .

Try LATEST BETA Drivers too . i had similar issue with my nvidia card untill i tried latest BETA Driver & it got Fixed .

turn off any VSYNC & triple BUffering from global settings of Nvidia Control panel

BY THE WAY . HAVNT YOU FORGOT TO CHANGE BACK THE POWER OPTION FROM POWER SAVING TO BALANCED ? people sometimes forget to do so .

m
0
l

Best solution

October 25, 2013 3:37:17 AM

sorry for this late rply but i found a fix. well, it's not an official fix but i used d3doverrider and i force the vsync and triple buffering there, and it fixed the problem. but i still don't know what's causing the problem
Share
!