When I Installed Windows, my keyboard stopped working just on that SSD, but my mouse still worked

I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed
11 answers Last reply
More about installed windows keyboard stopped working ssd mouse worked
  1. ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi
  2. Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi



    not sure. Il take a look though.
  3. Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!
  4. ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi
  5. Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi



    Sorry i haven't replied in a few days. I used a wireless keyboard, and it worked. My only problem was that the internet was still not working on that drive. My other drive is also now taking 2 minutes to connect to the internet and officially startup.
  6. Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi



    Also, what would your suggestion do?
  7. ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi



    Also, what would your suggestion do?


    AHCI Mode allows the SSD to work faster and also enables the Trim function, which is important for SSD operation.

    Yogi
  8. Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi



    Also, what would your suggestion do?


    AHCI Mode allows the SSD to work faster and also enables the Trim function, which is important for SSD operation.

    Yogi



    I could not find this option in my bios
  9. ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi



    Also, what would your suggestion do?


    AHCI Mode allows the SSD to work faster and also enables the Trim function, which is important for SSD operation.

    Yogi



    I could not find this option in my bios


    Look for "SATA Mode" or "SATA Options"

    Is your BIOS up to date?

    Yogi
  10. Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi



    Also, what would your suggestion do?


    AHCI Mode allows the SSD to work faster and also enables the Trim function, which is important for SSD operation.

    Yogi



    I could not find this option in my bios


    Look for "SATA Mode" or "SATA Options"

    Is your BIOS up to date?

    Yogi


    bro help me too please.
    urecken121@hotmail.com
    send me please!!!
  11. Funky_Buddha said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    Y0GI said:
    ryon137 said:
    I installed Windows 7 Ultimate on an SSD and it worked but the keyboard didn't work. The mouse does. Also the internet wont work either. My guess is drivers were not properly installed


    Prolly a good guess. How does device mgr look? Any yellow (!) or (?)?

    Yogi


    I couldn't really do anything because pretty much none of the drivers were working. So I am re-installing windows and I will see what happens!


    Good idea! Before you do though, go into the BIOS and be sure that your SATA Mode is set to AHCI and NOT RAID or IDE.

    Good luck!

    Yogi



    Also, what would your suggestion do?


    AHCI Mode allows the SSD to work faster and also enables the Trim function, which is important for SSD operation.

    Yogi



    I could not find this option in my bios


    Look for "SATA Mode" or "SATA Options"

    Is your BIOS up to date?

    Yogi


    bro help me too please.
    urecken121@hotmail.com
    send me please!!!


    Please start a new thread and tell us what your problem is. That way, all can benefit from the conversation.

    Yogi
Ask a new question

Read More

SSD Mice Windows 7 Keyboards