Sign in with
Sign up | Sign in
Your question

External USB, Recognised by DM, but not My Computer or BIOS

Last response: in Storage
Share
October 8, 2013 9:14:32 AM

Running Windows 7. Motherboard: Asus M4N98TD Evo

Model: Seagate Expansion 1TB Portal Drive. SRD00F1

When plugged in/out I get the 'Ba-Ding'/'Ba-Dum'.

In Device Manager it comes up alongside my Samsung Internal, under 'Disk Drives' as 'Seagate Expansion USB Device'.

With the Seagate app, I'm able to 'Add a new Drive' and detect it, and partition it.... however even after doing this and the prompted reboot, no luck.

It is not recognised in the BIOS, however, under the USB section of my BIOS it IS recognised, and selected as a 'Hard Drive'.

It is not recognised in My Computer, only my C Drive and DVD Drive are.

The light is on and solid on the unit at all times.

It seems everything recognises it but 'My Computer' / Bios. Any help would be appreciated.
a b G Storage
October 8, 2013 9:31:01 AM

sounds like a new drive never formatted.
use the disk management tool to format it if I am correct.
control panel / admin tools / computer management / disk management
m
0
l
October 8, 2013 9:57:51 AM

Tried that, not recognised there either mate :( 

Scrap that. It is recognised I think...

THere's Disk 0 (Which has System Reserved and C:) 

There's Disk 1 (Which is 931.51GB)

And there's DVD Drive...

When I right click Disk 1, and try to format it though I get various errors...
m
0
l
Related resources
October 8, 2013 10:38:36 AM

OK after a little more fiddling, I managed to erase what was a premade partition on the disk and make it completely unallocated.

Then I was able to R click it, and make a new 'Simple Volume' (only option not greyed out).

Now my Computer Management screen has a permanent windows 7 loading cursor... Not sure if this is because the reformat will take some time or because its bugged/frozen...


I've just tried uninstalling the USB drivers for Mass Storage, unplugging and plugging back in. Popped up saying installing, successfully installed, and even recognized it as the Seagate USB Mass Storage.... but still NOTHING in My Computer...

EDIT: OK after all that loading it just came up with an error message. Could not be completed....

'The operation failed to complete because the disk management console view is not up to date. Refresh the view by using the refresh task. If the problem persists close the Disk Management console, then restart Disk Management or restart the computer.'

Tried doing the format after a restart with no other programs opened (other than autoruns) and still getting the lame message... gonna have a broken window in a minute -.-
m
0
l
October 8, 2013 11:09:31 AM

Went into start and typed 'diskpart', ran as admin, typed 'volume list' and it brought up C drive (both the main partition and the system reserve) and the DVD drive.... no USB drive in there detected...
m
0
l
October 8, 2013 11:16:36 AM

SOLVED!: I noticed in Device Manager under 'Other Devices', I had an unknown whenever I plugged the Drive in. I right clicked, went onto Update Driver (bearing in mind I had already done this in BOTH USB and Disk Drives sections which is where the Hard Drive was appearing) and Scanned C:\Windows for the Driver. It installed it as 'Generic Mass' or something similar. Now It's detected in My Computer. Thank god for that!
m
0
l
!