Sign in with
Sign up | Sign in
Your question
Solved

Weird problem with brand new GPU

Last response: in Graphics & Displays
Share
October 8, 2013 1:20:31 PM

Hello guys this is my 1st post to this forum.

Today i have purchased a new graphic card ASUS GTX 770 2GB DDR5 DC II OC
after installing this card i was amazed with its performance played several games ex.farcry3,crysis 3, tomb raider, metro last light was enjoying thoroughly.
but when starting sleeping dogs weird thing happened while double clicking the game icon my display went out.
after that i reset my pc and went up to starting screen then sudden blackout BAM.... no display but the CPU was running.
after that resetted my pc again now there was no display from the beginning.
thn my card has got two dvi ports and i think two hdmi....connected to another dvi port and everything was ok since then but unable to play sleeping dogs while other games are working fine..

so is there anything wrong with my card or its just the drivers
my specs are:

1.ASUS GTX 770 2GB DDR5 DC II OC (nvidia driver 320.49-desktop-win8-win7-winvista-32bit-english-whql)
2.asus mobo p8p67 pro
3.corsair vengeance 8gb ddr 3
4.corsair 850 watts smps
5.intel core i7 2600k

Best solution

a b U Graphics card
October 8, 2013 1:35:41 PM

It's the GPU or PSU... download speedfan and monitor your Voltage if the 12 volt rail is good then most likely it a new defective GPU.
Share
October 8, 2013 1:44:57 PM

anonymous1 said:
It's the GPU or PSU... download speedfan and monitor your Voltage if the 12 volt rail is good then most likely it a new defective GPU.


thanks for the quick reply i will definitely do that and reply.
m
0
l
Related resources
October 8, 2013 11:52:14 PM

Every game was working fine except sleeping dogs, now both my DVI ports were working fine.
as yes one of the DVI port was not working Yesterday.

what a weird problem..
i will be monitoring this problem and see if this problem is solved
m
0
l
a c 156 U Graphics card
October 9, 2013 12:11:19 AM

I had a similar problem with one of my HD 7870XTs when I crossfired them. It was a bad card.
m
0
l
!