Sign in with
Sign up | Sign in
Your question
Solved

Laptop connects wirelessly to router but gives No Internet Access

Last response: in Wireless Networking
Share
October 8, 2013 11:47:43 PM

Hello,
I feel I've searched high and low for an answer that allows my new Windows 7 laptop to connect wirelessly to my Linksys WRT54G router and the internet. The toolbar on the desktop (of my laptop) indicates that I am connected to the correct wireless connection with a full five bars but it says "No Internet Access." I've tried a few tricks including resetting my router through 192.168.1.1 as well as the reset button but no luck. My laptop is able to connect to the internet when plugged in via ethernet cord to the router and it's also able to connect to the internet wirelessly with the second router in my house, a Linksys WRT120N. I would settle for this router but the signal is not strong and sometimes it is unable to connect at all or it is slow and unreliable. I would elaborate more thoroughly but I thought it would be more informative (and way more fun!) to draw you a picture:

I'm assuming it is the Linksys WRT54G in my room that is the problem. Any ideas? Thanks for your time guys!

More about : laptop connects wirelessly router internet access

a b D Laptop
October 8, 2013 11:55:57 PM

look at the rev of the unit on the bottom and try updating the firmware on the unit. if not working try using tomato or another third party firmware. if it not a firmware issue then it a chipset issue between then router and your laptop.
m
0
l
October 9, 2013 12:34:20 AM

Wow thank you for the fast reply smorizio. I actually had to Google "firmware" because I had no idea what it is:)  My router is version 2, it is ancient, so it definitely needed the firmware update but that didn't do the trick. Could there be some setting in 192.168.1.1 that I should try out or a setting that may not be matching up on my laptop? Again thank you for the reply and your time!
m
0
l
Related resources
a b D Laptop
October 9, 2013 12:41:45 AM

try turning off wep/wpa see if it log on to an open wifi. if it does try wpa or wep again with the same password. (make sure the wep or wpa key is the same for both units) if not you wont log on.
m
0
l

Best solution

a b D Laptop
October 9, 2013 12:45:43 AM

http://www.polarcloud.com/tomato
also try this may be newer firmware may work if not time to replace your router.
Share
October 10, 2013 4:38:34 PM

Thank you again smorizio. I tried tomato, no luck. I just bought a new router today, Netgear Wireless Dual Band Router WNDR3400 v3 N600, and still the same problem. I cannot connect to the internet but I connect to the router just fine. Actually strangely enough I connected to the internet through it momentarily when I first tried it and was able to use Google for about one minute. Then back to the same old. Again, my laptop is able to connect weakly to the router on the other side of my house wirelessly, but quite unreliably.
m
0
l
June 11, 2014 8:56:43 AM

smorizio said:
look at the rev of the unit on the bottom and try updating the firmware on the unit. if not working try using tomato or another third party firmware. if it not a firmware issue then it a chipset issue between then router and your laptop.


smorizio, I have a netgear router 750N (2ke1147301a93 serial) with same issue. firmware is uptodate and it is connectng to several devices fine. Even allows my MagicJack to function perfectly for VOIP. Have two tivos (digital television recording devices) to connect to internet, but two win 7 laptops wont connect to internet. Laptops can see and connect to all devices as well, but no internet.

Can you help me?
m
0
l
!