ATI Radeon HD 7770 2GB DDR5 on GA-G41M-ES2H (rev. 1.0) Stuck at Windows 7 Splash Screen

I have tried installing ATI Radeon HD 7770 card in my system and installed the driver first before the card. I got the machine boot up, it can display my dual screens while booting up and I can access BIOS but when it start loading Windows 7, it was stuck at the splash screen when the four coloured dots starting to appear. The sytem just stopped. I turned it off and removed the card, everything was back to normal again.

Here is my setup:

CPU: Core 2 Quad Q9400 2.7 GHz
MB: GA-G41M-ES2H (rev. 1.0)
RAM: 2 x 2GB DDR2 PC2-6400
Drive: SATA 2 - 3Gb/s 300GB
PSU: OCZ Extreme Mod 500Watt
OS: Windows 7 64bit

Can anyone shine my some light? is the video card not compatible with my mobo? Thanks a lot in advance.
8 answers Last reply
More about ati radeon 7770 2gb ddr5 g41m es2h rev stuck windows splash screen
  1. make sure intel chipset drivers and gpu drivers are updated. in the bios try setting an irq to the pci slot and not auto...the gpu and the onboard video trying to use the same irq. could be a bios bug with the mb chipset and your gpu if you can try nvidia card see if the mb locks up.
  2. probably installed the wrong drivers... hit f8 right after the bios splash screen and keep hitting it till you get the start menu, load into safe mode. go into device manager, open up display adaptors uninstall EVERYTHING. restart the computer load into windows normally. install the latest radeon drivers.
  3. smorizio said:
    make sure intel chipset drivers and gpu drivers are updated. in the bios try setting an irq to the pci slot and not auto...the gpu and the onboard video trying to use the same irq. could be a bios bug with the mb chipset and your gpu if you can try nvidia card see if the mb locks up.

    Thanks for the reply, I have tried irq to PCI-E but that didn't help either.
  4. I just found out more about the situation.... First of all the Card was actually pulled out from an HP machine, I got it second hand, second this is a PCI-E 3.0 card while the Mobo is 2.0 , but I searched on-line and found that PCI-E 3.0 card are backward compatible with the 2.0 slots.... so I am still confused... I just tried uninstall the G41 drivers, same thing didn't work. and then I tried to even reinstall windows with the Radeon 7770 plugged in, same thing, the Windows loading screen was stuck at the same place....
  5. try the card in a different machine. it might be a bum card.
  6. ingtar33 said:
    try the card in a different machine. it might be a bum card.


    Thanks for your reply. so a HP card should work in other system as well?
  7. yeah
  8. Installed it on a MSI G41M-P33 Combo mATX LGA775 G41 DDR3 1PCI-E16 1PCI-1 1PCI VGA SATA2 USB2.0 Motherboard and it worked! only problem is the card is cover two of the SATA2 sockets..... but thanks for eveyone's info
Ask a new question

Read More

ATI HD Graphics Windows 7 Splash Screen Radeon