Solved

When i try to open angry birds game , there comes an error which says opengl2.0 render not supported. what should i do?

When i try to open angry birds game , there comes an error which says opengl2.0 render not supported. what should i do?
3 answers Last reply Best Answer
More about open angry birds game error opengl2 render supported
  1. Best answer
    Now,that's because you haven't installed your Display driver properly. Go to Control Panel------>Device manager-------->Display Adapter and make sure you have the latest drivers updated. If you haven't,insert you MB CD,and install the display drivers. Or you could download the latest drivers from your MB manufacturer's website and install them.
  2. upgrade your graphic card.
  3. Seriously,it's the driver mate... :)
    Just give it a try...Update the driver,and it will work that's for certain....
Ask a new question

Read More

Games Windows 7