Sign in with
Sign up | Sign in
Your question

Windows 7 welcome screen displays glitched graphic and freezes.

Last response: in Graphics & Displays
Share
October 17, 2013 2:50:36 PM

After getting a corsair cx600w modular psu to swap out my old one since my gtx 660 was overpowering it, after installation it booted up fine untill i tried to log in, a very glitchy screen, very pixelated pink background with green squares everywhere, suddenly was displayed, and as expected the gpu was at fault ( i prooved this as the motherboard chipset was working fine when i plugged it in). What happened? Even after trying again with the old psu the result was still the same: the pink background with green squares. I hope i don't need to replace my gpu.
**Edit**
I Forgot to mention that i can only go onto safe mode with the gtx 660 that i have. I tested my old gpu, a gt 610, everything worked perfectly fine. that confirmed that there was nothing wrong with the pci slot.
a b $ Windows 7
October 17, 2013 3:03:21 PM

have you reseated your gpu?? if you did check for dirt in the pci slot and damage on your gpu.
m
0
l
October 18, 2013 11:38:31 AM

smorizio said:
have you reseated your gpu?? if you did check for dirt in the pci slot and damage on your gpu.

I checked for dirt on the slot, there was none, and as far as i can tell, the gpu has nothing damaged and/or out of place. Even the an old gt 610 that i had in the past worked perfectly when i replaced the new gpu with the old one today.
m
0
l
a b $ Windows 7
October 18, 2013 11:48:23 AM

if the 610 is working fine then looks like some ram or the gpu chip went bad on the new gpu.
m
0
l
!