Sign in with
Sign up | Sign in
Your question
Solved

No display when inserting graphic card.

Tags:
  • GPUs
  • Graphics Cards
  • Graphics
  • Displays
Last response: in Graphics & Displays
Share
October 19, 2013 7:47:23 PM

I bought a new powercolor amd/ati radeon hd 7750 1 GB GDDR5 gpu nad when i inserted it their was no display,the fan of the gpu was working.Previously i had a nvidia geforce 210 512 mb which worked fine.So is it a problem of the gpu?

More about : display inserting graphic card

October 19, 2013 7:53:53 PM

Did you put the power cables? High end graphics card needs extra power beyond what the slot can provide.
m
0
l
a c 95 U Graphics card
October 19, 2013 8:04:33 PM

7750 does not generally need power cables.

What type of monitor connection? DVI or VGA?

What type of mobo do you have?
m
0
l
Related resources

Best solution

a b U Graphics card
October 19, 2013 8:09:04 PM

Oh hey, it's you
I remember you !!!!

It seems you took my recommendation. Good Choice bro !

There could be many problems such as,
- The PSU doesn't provide enough power
- You did not connect the wires from the GPU to the monitor properly
- The GPU is not inserted properly
- CPU Bottleneck
- Monitor problem

There's many more , but these are some
Share
a b U Graphics card
October 19, 2013 8:15:19 PM

Although you do not need the connect any wires from the PSU to the GPU ,you still need some power
m
0
l
a b U Graphics card
October 19, 2013 8:15:58 PM

Maybe there's a problem with the VGA , try the DVI or HDMI one
m
0
l
October 21, 2013 7:08:15 AM

hey i have an xfx hd 6770 1gd ddr5 buy it new band worked about 4 month then suddenly when i turn on my pc its not turning on but when i take oyt the graphic card the computer is booting up but when i put in back the card is not booting up
m
0
l
a b U Graphics card
October 21, 2013 7:16:13 AM

chanders said:
hey i have an xfx hd 6770 1gd ddr5 buy it new band worked about 4 month then suddenly when i turn on my pc its not turning on but when i take oyt the graphic card the computer is booting up but when i put in back the card is not booting up


Hello there

You must be new here ! Welcome!
But you shouldn't be asking on solved threads AKA discussions. If you have a question , simply enter the Graphics and Display forum , and you should see an option to " ask the community ".

See you in your new thread !
m
0
l
!