Sign in with
Sign up | Sign in
Your question
Solved

Black Screen After Updating To Windows 8.1

Last response: in Windows 8
Share
October 20, 2013 1:24:00 AM

Yesterday, for whatever reason I decided to download windows 8.1 since it was a free download. After the download it rebooted fine. I rebooted it again for whatever reason and got a black screen after the blue windows logo shows up.

This is a custom built computer also.

After a bunch of reboots I was finally given the option to boot with advance settings and I tried to do system restore. But the only system restore point I had was the 8.1 upgrade.

So I googled the problem and I saw alot of notebook users having the same problem due to some graphic drivers.

I went into safe mode uninstalled my amd drivers, did drive sweeper or whatever, and restarted. I then downloaded the 13.11 amd drivers http://support.amd.com/en-us/kb-articles/Pages/latest-c... (in safe mode)

I tried to install them but I got an error saying it failed to load detection driver. Googled the problem and apparently you can't install drivers in safe mode. So now I'm stuck...and I'm not even sure if that's the problem.

I don't have the flash drive that I used to install windows 8 with, nor do I even have a flash drive...so im stuck. I'm stressed out and about to go to sleep so if anyone has any solutions please post them.

Specs:

Sapphire 7950
3570k
Asrock z77 mini itx mobo
WD 1tb blue

Best solution

October 20, 2013 4:36:10 AM

You shouldn't need to install amd drivers to get into windows anyhow
As window generic drivers will work
So doubt it's those drivers problem

Do you have the intel graphics enabled aswell?
As I read there's problem with their latest drivers

I had similar problems as well
With lucid MVP installed
Had to uninstall it in safe mode to fix
Share
October 20, 2013 8:51:27 AM

Smilie said:
You shouldn't need to install amd drivers to get into windows anyhow
As window generic drivers will work
So doubt it's those drivers problem

Do you have the intel graphics enabled aswell?
As I read there's problem with their latest drivers

I had similar problems as well
With lucid MVP installed
Had to uninstall it in safe mode to fix


I tried disbaling both amd and intel drivers, and just disabling the intel drivers, none of those worked. But after uninstalling mvp vitru and disabling the intel graphics IT WORKED!

It sat on the black screen for longer than usual so I thought it wasn't going to work lol.

Thanks so much!

Edit: After a couple of restarts it still gets caught up on the black screen for a little while. It eventually loads, but it doesn't load as fast as it did before I installed 8.1.

What driver do I need to download?



Don't...

Bump posts


http://www.tomshardware.com/forum/283384-33-read-first
m
0
l
!