Sign in with
Sign up | Sign in
Your question
Solved

Asus Matrix Platinum R9 280X install problem.

Last response: in Graphics & Displays
Share
October 20, 2013 10:59:32 AM

Hi everyone. I just bought the above graphics card and was super excited to get it all installed but I am having trouble.

I uninstalled my old HD7850 and the drivers for it.

The card is all installed and lights up, including the two green lights on the power connectors. I do not get any display signal when I use the outputs on the card (expected this with no drivers) so I have my HDMI cable plugged into my motherboard output.

I went to the Asus website and tried to download the drivers. I can download the GPU Tweak program but the drivers for the card keeps coming up with "Cannot Find File" when I try to download.

I tried to install from the CD but it comes up with a box saying "Please install an Asus VGA Card" or something like that (can't remember exactly and I'm at work now).

Can you let me know what to try next? I am guessing it is something in the bios. Also, please remember I am an extreme novice at this stuff!

CPU: i5 3570K @ 4.2GHz
Mobo: Gigabyte Z77X - UD3H
PSU: Seasonic 750W

Also, I am not getting any sound since I installed the card... could this be related?

Best solution

October 20, 2013 11:03:05 AM

First of all you shouldn't have uninstalled your display drivers. They would have worked with your new GPU.

I would go to AMD's website and download and install display drivers directly instead of through a third-party program.
Share
October 20, 2013 8:52:12 PM

Sorted it out but now I have no audio. There is no HDMI outlet on the card so I have to use the DVI adapter. Could there be a problem with the adapter?
m
0
l
Related resources
October 24, 2013 6:44:16 AM

I have got the same issues with my card. Pc boots to windows but i have a black screen.. how did you solve that?
m
0
l
January 7, 2014 7:32:45 AM

visstick said:
I have got the same issues with my card. Pc boots to windows but i have a black screen.. how did you solve that?


Plug your display into your mother board directly... if you have a newer CPU then it should have its' on GPU on the chip or your MOBO will have it's own display drivers.... then go to the AMD site... Download the drivers for your card.... and install.

m
0
l
!