Sign in with
Sign up | Sign in
Your question

Homebuilt PC: No beep, no display, but all the fans work

Last response: in Systems
Share
October 20, 2013 11:19:13 AM

Yesterday I received all my computer parts and I put them all together. Everything is connected correctly (at least that's what I think). The problem is, when I turn on the computer, I'm not getting any display and the bios won't load. Completely NOTHING appears on the monitor, it's just a black screen. Also my hdd and cd drive don't have lights on. Please help. Thanks
Additional Details
My parts are:

Intel Core i5-3470 Processor: http://amzn.to/1avZ9xG

MSI B75MA-P45 Motherboard: http://amzn.to/12a7hei

XFX Radeon HD 7950: http://amzn.to/1aw1KaW

8GB Corsair Vengeance DDR3 RAM: http://amzn.to/ZkATWc

1TB Western Digital Caviar Black Hard Drive: http://amzn.to/1beD3Mh
a b B Homebuilt system
October 20, 2013 11:26:35 AM

on the top right of the mb is a black four pin power plug is the four pin power from the mb connected???
http://us.msi.com/product/mb/B75MA-P45.html
did you use all the mb standoffs to keep the mb from grounding out??
m
0
l
October 20, 2013 11:35:34 AM

umm... i don't know what you mean by "grounding out" but yes the four pin power is connected to the mb. It's the one that says cpu right?
m
0
l
Related resources
October 20, 2013 11:38:30 AM

the CABLE that says CPU
m
0
l
a b B Homebuilt system
October 20, 2013 12:54:18 PM

if the bottom of the motherboard hits the bottom of the mb tray without the brass standoffs under in your shorting the mb out. (dead short)
m
0
l
October 21, 2013 8:38:03 AM

smorizio said:
if the bottom of the motherboard hits the bottom of the mb tray without the brass standoffs under in your shorting the mb out. (dead short)


???
m
0
l
!